1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

As Designed Error message outside fixed width area when using plain text editor

Discussion in 'Resolved Bug Reports' started by Brogan, Aug 26, 2010.

  1. Brogan

    Brogan XenForo Moderator Staff Member

    Quite pleased with this catch :D

    If you use the plain text editor and click on Create Thread with no message, there is an additional error message displayed on the right which is outside the fixed width area.

    See the screenshot below.

    error.PNG
     
  2. Shadab

    Shadab Well-Known Member

    Happens with the RTE as well. (using the fixed width style)
    Tested on Firefox 3.6.8:

    Message_outside_boundary.png
     
  3. Mike

    Mike XenForo Developer Staff Member

    This is as designed. Errors that can be associated with a particular field are put to the right of the field. You can see this if you flip to the plain text editor and leave everything blank. It also happens on various account pages. We don't want to put the errors inline because that would cause page reflows.

    (Because of the structure of the WYSIWYG editor, it's not possible to associate an error with that.)
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Ah fair enough, thanks Mike.

    I was feeling quite smug about that too :D
     
  5. Shadab

    Shadab Well-Known Member

    I usually use 1152 x 864 resolution so this is not an issue for me. But for those on the lesser resolutions (eg. 1024 x 768), a part of the error message box overflows the browser viewport and causes a horizontal scrollbar to appear.

    Message_Outside_Viewport.png
     

Share This Page