• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Error in OPTIMIZE TABLE xf_template

Chris D

XenForo developer
Staff member
#2
How would this be an XF bug? The software itself doesn't run that query, so presumably you're running it directly, or via some sort of client like PhpMyAdmin.

This kind of error would usually be related to a timeout or other limits.

Try adjusting wait_timeout and max_allowed_packet values in MySQL.
 

vinafix

Active member
#3
I do not see it
wait_timeout
max_allowed_packet

in my.cnf

datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0
# Settings user and group are ignored when systemd is used.
# If you need to run mysqld under a different user or group,
# customize your systemd unit file for mariadb according to the
# instructions in http://fedoraproject.org/wiki/Systemd

[mysqld_safe]
log-error=/var/log/mariadb/mariadb.log
pid-file=/var/run/mariadb/mariadb.pid

#
# include all files from the config directory
#
!includedir /etc/my.cnf.d
 

Mike

XenForo developer
Staff member
#6
This is more likely to indicate internal InnoDB corruption, though it could also indicate that you don't have disk space for what you're trying. Look at your MySQL log to see if there's anything of note in there.