1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Error cant install any addons

Discussion in 'Installation, Upgrade, and Import Support' started by Stormnetwork, Mar 17, 2014.

  1. Stormnetwork

    Stormnetwork Member

    1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    3. Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
    4. XenForo_Model->fetchAllKeyed() in XenForo/Model/StyleProperty.php at line 79
    5. XenForo_Model_StyleProperty->getStylePropertiesInStyles() in XenForo/Model/StyleProperty.php at line 130
    6. XenForo_Model_StyleProperty->getEffectiveStylePropertiesInStyle() in XenForo/Model/StyleProperty.php at line 2319
    7. XenForo_Model_StyleProperty->importStylePropertiesFromArray() in XenForo/Model/StyleProperty.php at line 2305
    8. XenForo_Model_StyleProperty->importStylePropertyXml() in XenForo/Model/AddOn.php at line 332
    9. XenForo_Model_AddOn->importAddOnExtraDataFromXml() in XenForo/Model/AddOn.php at line 226
    10. XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
    11. XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 187
    12. XenForo_ControllerAdmin_AddOn->actionInstall() in XenForo/FrontController.php at line 347
    13. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    14. XenForo_FrontController->run() in /var/www/admin.php at line 13
    please help



     
  2. Chris D

    Chris D XenForo Developer Staff Member

    You have missed one of the important parts of the error message.

    Also, what XenForo version? What add-ons specifically?
     
  3. Stormnetwork

    Stormnetwork Member

    Mysqli statement execute error : Incorrect key file for table '/tmp/#sql_3057_0.MYI'; try to repair it


    ive tried installing multiple addons with the same error message.

    im using 1.3
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    This is a MySQL issue. It's possible that the /tmp directory is running out of disk space.
     
  5. Stormnetwork

    Stormnetwork Member

    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Incorrect key file for table '/tmp/#sql_3057_0.MYI'; try to repair it - library/Zend/Db/Statement/Mysqli.php:214

    #0 /var/www/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
    #1 /var/www/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
    #2 /var/www/library/XenForo/Model.php(219): Zend_Db_Adapter_Abstract->query('?????SELECT pro...', Array, 2)
    #3 /var/www/library/XenForo/Model/StyleProperty.php(79): XenForo_Model->fetchAllKeyed('?????SELECT pro...', 'property_id')
    #4 /var/www/library/XenForo/Model/StyleProperty.php(130): XenForo_Model_StyleProperty->getStylePropertiesInStyles(Array)
    #5 /var/www/library/XenForo/Model/StyleProperty.php(2319): XenForo_Model_StyleProperty->getEffectiveStylePropertiesInStyle(0)
    #6 /var/www/library/XenForo/Model/StyleProperty.php(2305): XenForo_Model_StyleProperty->importStylePropertiesFromArray(Array, Array, 0, 'HeroDev_Minecra...')
    #7 /var/www/library/XenForo/Model/AddOn.php(332): XenForo_Model_StyleProperty->importStylePropertyXml(Object(SimpleXMLElement), 0, 'HeroDev_Minecra...')
    #8 /var/www/library/XenForo/Model/AddOn.php(226): XenForo_Model_AddOn->importAddOnExtraDataFromXml(Object(SimpleXMLElement), 'HeroDev_Minecra...')
    #9 /var/www/library/XenForo/Model/AddOn.php(169): XenForo_Model_AddOn->installAddOnXml(Object(SimpleXMLElement), false)
    #10 /var/www/library/XenForo/ControllerAdmin/AddOn.php(187): XenForo_Model_AddOn->installAddOnXmlFromFile('/tmp/phpJMFMgt')
    #11 /var/www/library/XenForo/FrontController.php(347): XenForo_ControllerAdmin_AddOn->actionInstall()
    #12 /var/www/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #13 /var/www/admin.php(13): XenForo_FrontController->run()
    #14 {main}

    array(3) {
    ["url"] => string(40) "http://mcsn.us/admin.php?add-ons/install"
    ["_GET"] => array(1) {
    ["add-ons/install"] => string(0) ""
    }
    ["_POST"] => array(3) {
    ["server_file"] => string(0) ""
    ["_xfConfirm"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    }
    }
     
  6. Chris D

    Chris D XenForo Developer Staff Member

     
  7. Stormnetwork

    Stormnetwork Member

    there is enough space available(like 100 gb)
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    Similar reports of the issue have been caused by mod_security:
    http://xenforo.com/community/threads/server-error.25393/#post-307971

    And others have been ascertained as a possibly buggy MySQL build:
    http://xenforo.com/community/threads/server-logs-errors.24927/#post-304177

    I've also seen elsewhere reports that it seemed that disk space was plenty, but the tmp tables were being created on a much smaller, and nearly full partition.

    If you haven't already I would suggest opening a ticket with your host.
     

Share This Page