1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Enabling Use Full Friendly URLs

Discussion in 'Troubleshooting and Problems' started by dtommy79, Jul 31, 2014.

  1. dtommy79

    dtommy79 Member

    Hi,

    I installed the forum and when I go to the settings and want to enable the "Use Full Friendly URLs" option and I go to my forum main page it wants to start the installation again. What am I doing wrong?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. dtommy79

    dtommy79 Member

    Yes, I did. And whenever I try to access my main page, it redirects me to the install page.

    But I can access the administration.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    What do you mean by your "main page"?

    The forum index or a landing page?

    What is the link to your site?

    What is the content of your .htaccess file?
     
  5. dtommy79

    dtommy79 Member

    Yes, I meant the index page. But I think it might be some kind of browser issue, because when I switched to Chrome the forum was ok.

    I installed the forum from Firefox and whenever I try to access the forum it redirects me to the install page.

    This is the content of the .htaccess file:

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        RewriteBase /forum
    
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    If it works in Chrome then it could be a browser cache issue.

    Force clear the cache in Firefox - CTRL+F5.
     

Share This Page