1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Emails going as plain text

Discussion in 'Troubleshooting and Problems' started by Pride1760, Jan 2, 2012.

  1. Pride1760

    Pride1760 Member


    All automatic emails (watched threads, email confirmation, new registrations, etc..) sent from my board have that blue box that contains the message along with other info about unsubscribing, etc..

    However, when I am sending an email to all users by going to Admin CP-->Users-->Email Users, the email is being sent as plain text with just the email message and absolutely nothing else.

    Is this normal behaviour? I thought the blue box was the default template and any emails I sent would be in it. If it is normal behaviour, how can I send emails that look like the other automatic emails?

  2. Brogan

    Brogan XenForo Moderator Staff Member

    Set the email format as HTML.

  3. Pride1760

    Pride1760 Member

    Setting it to HTML is sending the same plain text message except that now, it has no formatting (i.e no paragraphs etc... just continuous text.)
  4. Brogan

    Brogan XenForo Moderator Staff Member

    You need to add your markup as the template is blank.
  5. Pride1760

    Pride1760 Member

    But shouldn't the email text be inside the blue box like the automatic emails sent from the board?

  6. Brogan

    Brogan XenForo Moderator Staff Member

    You can copy the styling of one of the email templates, you will need to enable debug mode to access them though.
  7. Pride1760

    Pride1760 Member

    OK, just wanted to confirm if this was normal. Prior to 1.1, the emails I sent had the default styling. But now it looks like I will have to edit every email I send to insert the styling HTML :(

    By the way, you wouldn't happen to have the default template HTML lying around, would you? :p
    Because I just searched for it and enabling debug mode seems to require some file editing etc which I am not very comfortable with.
  8. Brogan

    Brogan XenForo Moderator Staff Member

    There are lots of email templates so you need to choose the one you want.

    Enabling debug mode is very simple.
    Edit the library/config.php file and add the following:
    $config['debug'] = true;
  9. Pride1760

    Pride1760 Member

    OK, I will take a look at that. Thanks for such fast response, Brogan!

    From another thread, I found that I can access the templates at: Admin CP -> Development -> Email Templates

    Is there any way that once I get the styling, I can make it the default for any future emails I manually send?
    Digital Doctor likes this.
  10. Digital Doctor

    Digital Doctor Well-Known Member

    Sounds like the default template should be available ? but with the option to choose another ?

    I think I am the only person in the world whom only allows Plain Text emails.
    Always seemed like a security problem to allow HTML.
    Is that old school thinking ? :)
  11. Pride1760

    Pride1760 Member

    I finally got the template and sent the mail, however, I got this error:

    Server Error

    fwrite() [function.fwrite]: SSL operation failed with code 1. OpenSSL Error messages: error:140D00CF:SSL routines:SSL_write:protocol is shutdown
    1. XenForo_Application::handlePhpError() in Zend/Mail/Protocol/Abstract.php at line 324
    2. Zend_Mail_Protocol_Abstract->_send() in Zend/Mail/Protocol/Smtp.php at line 385
    3. Zend_Mail_Protocol_Smtp->quit() in Zend/Mail/Transport/Smtp.php at line 144
    4. Zend_Mail_Transport_Smtp->__destruct() in XenForo/FrontController.php at line 310
    5. XenForo_ControllerAdmin_User->actionEmailSend() in XenForo/FrontController.php at line 310
    6. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    7. XenForo_FrontController->run() in /home/pride1760/public_html/admin.php at line 13

    I was sending the mail to just 400 members (1 user group).
    Is this something that I need to contact my Hosting Company about?
  12. Pride1760

    Pride1760 Member

    I have set up google SMTP by the way.

    All the other board emails are going out fine and the test email also got delivered without any errors.
  13. Brogan

    Brogan XenForo Moderator Staff Member

    Check your email settings in the ACP; you may need to adjust them.
  14. Digital Doctor

    Digital Doctor Well-Known Member

  15. Pride1760

    Pride1760 Member

    So you mean my host is limiting me from sending out these emails?

    I have sent a mail to them as well. Waiting for their response.

    @Brogan: email settings are fine, I think, because all other mails are getting delivered.

    Also, this is not the first time that I have sent an email to around 400 members. I don't know what has happened this time. First, the message is not being sent in the default template and now this error :(

Share This Page