1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email Sending Problem

Discussion in 'Troubleshooting and Problems' started by Josiah, Dec 8, 2012.

  1. Josiah

    Josiah Member

    I am trying to send out an email to a group (roughly 140 users) and I get the below error. I can send the same exact email to myself with no problem. I am currently using SMTP and got this with both TSL and SSL. I don't want to use the default -f because my emails get marked as SPAM =/


    Error Info
    ErrorException: fwrite() [<a href='function.fwrite'>function.fwrite</a>]: SSL operation failed with code 1. OpenSSL Error messages: error:140D00CF:SSL routines:SSL_write: protocol is shutdown - library/Zend/Mail/Protocol/Abstract.php:324
    Generated By: Pythros, Today at 4:22 PM
    Stack Trace
    #0 [internal function]: XenForo_Application::handlePhpError(2, 'fwrite() [<a hr...', '/home/uh_pxe/xp...', 324, Array)
    #1 /home/uh_pxe/xp-e.net/library/Zend/Mail/Protocol/Abstract.php(324): fwrite(Resource id #84, 'QUIT??')
    #2 /home/uh_pxe/xp-e.net/library/Zend/Mail/Protocol/Smtp.php(385): Zend_Mail_Protocol_Abstract->_send('QUIT')
    #3 /home/uh_pxe/xp-e.net/library/Zend/Mail/Transport/Smtp.php(144): Zend_Mail_Protocol_Smtp->quit()
    #4 /home/uh_pxe/xp-e.net/library/XenForo/FrontController.php(310): Zend_Mail_Transport_Smtp->__destruct()
    #5 /home/uh_pxe/xp-e.net/library/XenForo/FrontController.php(310): XenForo_ControllerAdmin_User->actionEmailSend()
    #6 /home/uh_pxe/xp-e.net/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #7 /home/uh_pxe/xp-e.net/admin.php(13): XenForo_FrontController->run()
    #8 {main}
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  3. Josiah

    Josiah Member

  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Well that's strange. Maybe you are hitting a sending quota when sending out a mass mail. Who is your mail host?
  5. Josiah

    Josiah Member

    It's Google. I know I'm not hitting the 500 per day max because I am still getting email notifications all day and the email I attempted to send out was the first time that particular email address was being used today.
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Well a connection error like this that is intermittent would have to be something on the mail host. Try contacting them.
  7. Josiah

    Josiah Member

    Fixed... I had to edit the TXT/spf record and then used the default -f option and it won't be flagged as SPAM.
    Jake Bunce likes this.
  8. When we try to send an email using the "Email Users" option in the ACP, the mail itself sends fine, to the default forum email. However, no one else gets it that we specify. Do I need to list their user names for this? We have 6 admins for our site, and use the Primary and Secondary user groups to narrow down exactly who gets the email. When I click continue, it does indeed show those listed based on the criteria for the Primary and Secondary. But, none of the 6 get the email except for our default email for the forums themselves.

    Now, if I send it to myself based on the same criteria above but list my name and email under the User Criteria area, I get the email.

    Shouldn't I get the email whether my user name is listed or not? Especially if we send it to our members, they should all be able to receive the email without me having to type each email address.

    Any ideas??
  9. Any ideas regarding this issue?? This all came up because our Simple Forms produced an error that they said was due to the "email" option, which isn't related to their software.
  10. Ferdinand

    Ferdinand Active Member

    This is interesting because I've been having the same problem the exact same error occurs, however I cannot switch to default because my email server is too slow; instead I have to patch the PHP https://code.google.com/p/jaxl/issues/detail?id=15

    And hope that I can send emails via SMTP after this. So your problem was related to the way your PHP communicated with google, apparently it's common. Sure wish I could just press the default button!

Share This Page