1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Email bounce system working even when mail disabled on config.php

Discussion in 'Resolved Bug Reports' started by imthebest, Sep 5, 2014.

  1. imthebest

    imthebest Formerly Super120

    Got the following error logged even when I have "$config['enableMail'] = 'false';" this on my config.php at my local installation:

    Code:
    Server Error Log
    Error Info
    Zend_Mail_Protocol_Exception: cannot connect to host; error = Permission denied (errno = 13 ) - library/Zend/Mail/Protocol/Pop3.php:109
    Generated By: Unknown Account, hace 8 minutos
    Stack Trace
    
    #0 /var/www/html/mysite/library/Zend/Mail/Storage/Pop3.php(190): Zend_Mail_Protocol_Pop3->connect('pop.gmail.com', 995, 'SSL')
    #1 /var/www/html/mysite/library/XenForo/Model/EmailBounce.php(288): Zend_Mail_Storage_Pop3->__construct(Array)
    #2 /var/www/html/mysite/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
    #3 /var/www/html/mysite/library/XenForo/Model/Deferred.php(256): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.9999990463257, '')
    #4 /var/www/html/mysite/library/XenForo/Model/Deferred.php(390): XenForo_Model_Deferred->runDeferred(Array, 7.9999990463257, '', false)
    #5 /var/www/html/mysite/library/XenForo/Model/Deferred.php(335): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #6 /var/www/html/mysite/deferred.php(23): XenForo_Model_Deferred->run(false)
    #7 {main}
    
    Request State
    
    array(3) {
      ["url"] => string(35) "http://192.168.1.20/mysite/deferred.php"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(3) {
        ["_xfRequestUri"] => string(4) "/mysite/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfResponseType"] => string(4) "json"
      }
    }
    
     
  2. thedude

    thedude Well-Known Member

    There should be no quotes around false i.e. $config['enableMail']= false;
     
    imthebest likes this.
  3. imthebest

    imthebest Formerly Super120

    Even after fixing that the email bounce system is still generating those error logs!

    Isn't supposed that $config['enableMail'] = false should disable everything related to the XenForo mail system?
     
  4. Mike

    Mike XenForo Developer Staff Member

    No. It disables sending via the mail helper class only. Bounce parsing is unrelated.
     

Share This Page