1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Errors logged from the Email Bounce Handler

Discussion in 'Troubleshooting and Problems' started by imthebest, Dec 15, 2014.

  1. imthebest

    imthebest Formerly Super120

    Code:
    Server Error Log
    Error Info
    Zend_Mail_Protocol_Exception: cannot connect to host; error = php_network_getaddresses: getaddrinfo failed: Name or service not known (errno = 0 ) - library/Zend/Mail/Protocol/Pop3.php:109
    Generated By: Unknown Account, Yesterday, 17:23
    Stack Trace
    
    #0 /var/www/html/library/Zend/Mail/Storage/Pop3.php(190): Zend_Mail_Protocol_Pop3->connect('pop.gmail.com', 995, 'SSL')
    #1 /var/www/html/library/XenForo/Model/EmailBounce.php(288): Zend_Mail_Storage_Pop3->__construct(Array)
    #2 /var/www/html/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
    #3 /var/www/html/library/XenForo/Model/Deferred.php(256): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.9999988079071, '')
    #4 /var/www/html/library/XenForo/Model/Deferred.php(390): XenForo_Model_Deferred->runDeferred(Array, 7.9999988079071, '', false)
    #5 /var/www/html/library/XenForo/Model/Deferred.php(335): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #6 /var/www/html/deferred.php(23): XenForo_Model_Deferred->run(false)
    #7 {main}
    
    Request State
    
    array(3) {
      ["url"] => string(37) "http://www.mysite.com/deferred.php"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(4) {
        ["_xfRequestUri"] => string(39) "/threads/test.6074/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
        ["_xfResponseType"] => string(4) "json"
      }
    }
    Code:
    Server Error Log
    Error Info
    Zend_Mail_Protocol_Exception: cannot connect to host; error = Connection refused (errno = 111 ) - library/Zend/Mail/Protocol/Pop3.php:109
    Generated By: Unknown Account, Yesterday, 02:53
    Stack Trace
    
    #0 /var/www/html/library/Zend/Mail/Storage/Pop3.php(190): Zend_Mail_Protocol_Pop3->connect('pop.gmail.com', 995, 'SSL')
    #1 /var/www/html/library/XenForo/Model/EmailBounce.php(288): Zend_Mail_Storage_Pop3->__construct(Array)
    #2 /var/www/html/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
    #3 /var/www/html/library/XenForo/Model/Deferred.php(256): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.9999990463257, '')
    #4 /var/www/html/library/XenForo/Model/Deferred.php(390): XenForo_Model_Deferred->runDeferred(Array, 7.9999990463257, '', false)
    #5 /var/www/html/library/XenForo/Model/Deferred.php(335): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #6 /var/www/html/deferred.php(23): XenForo_Model_Deferred->run(false)
    #7 {main}
    
    Request State
    
    array(3) {
      ["url"] => string(37) "http://www.mysite.com/deferred.php"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(4) {
        ["_xfRequestUri"] => string(20) "/forums/movies.17/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
        ["_xfResponseType"] => string(4) "json"
      }
    }
     
  2. Mike

    Mike XenForo Developer Staff Member

    These both seem to indicate network, DNS or availability issues. It could represent network problems on your end or availability issues on your POP3 server's end. Nothing you can directly do to change that within XenForo.
     

Share This Page