1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Automated Email Bounce not Working

Discussion in 'XenForo Questions and Support' started by directodigital, Jul 26, 2016.

  1. I am trying to get the automatic email bounce to process. I have tried POP and IMAP - the settings work on Thunderbird but not on XenForo.

    Here are my settings (I changed it for security/privacy reasons)

    [​IMG]


    The error log:

    [​IMG]


    In that error log:


    Stack Trace
    Code:
    #0 /home/forum/public_html/library/Zend/Mail/Protocol/Pop3.php(222): Zend_Mail_Protocol_Pop3->readResponse(false)
    #1 /home/forum/public_html/library/Zend/Mail/Protocol/Pop3.php(281): Zend_Mail_Protocol_Pop3->request('USER noreply')
    #2 /home/forum/public_html/library/Zend/Mail/Storage/Pop3.php(191): Zend_Mail_Protocol_Pop3->login('forum', 'emailpassword')
    #3 /home/forum/public_html/library/XenForo/Model/EmailBounce.php(288): Zend_Mail_Storage_Pop3->__construct(Array)
    #4 /home/forum/public_html/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
    #5 /home/forum/public_html/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.99999904633, '')
    #6 /home/forum/public_html/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.99999904633, '', false)
    #7 /home/forum/public_html/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #8 /home/forum/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
    #9 {main}
    Request State
    Code:
    array(3) {
      ["url"] => string(39) "http://www.forum.com/deferred.php"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(4) {
        ["_xfRequestUri"] => string(29) "/admin.php?tools/run-deferred"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
        ["_xfResponseType"] => string(4) "json"
      }
    }
    
    I have tried IMAP and POP neither are working. Ports are correct, password is correct.
    The server connects find to send out e-mails on this same server.
     
  2. Update: I changed the password not to have a special character in and it has just processed for the first time. Happy days!
     
  3. Hi, I set up the automated bounced email handler as attached, but now getting server errors (last request failed). There is now a gmail message that they blocked access until I allow "less secure apps" to access the bounced email account.? In the gmail admin, there is no such option. Am I doing something wrong here? Thank you everyone. Capture.PNG
     
  4. Mouth

    Mouth Well-Known Member

    Did you google this? I used "gmail less secure apps" and the first result is exact .... https://support.google.com/accounts/answer/6010255?hl=en
     
  5. Lol. Ok, kick in the ass accepted. Thanks. I waded thru gmail support site, found the button in admin for the domain, and then allowed less secure apps access. Seems to be fine now, no server errors in 2-3 days. Thank you.
     
    Mouth likes this.

Share This Page