• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Elasticsearch setup - Error 324 (net::ERR_EMPTY_RESPONSE)

MrC

Active member
#1
I have ES installed, searching is fine. But when I clicked Elasticsearch setup, I got the following error:

"Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data."

I suspect the reason I have been getting duplicated posts is port and ip were not setup correctly. But ES is running.

Edit: ps -A shows that elastisearch is running
Config was setup like this guide:
http://xenforo.com/community/thread...urned-from-elasticsearch-is-it-running.27009/

curl http://127.0.0.1:9200, only gave this:
Code:
{
  "ok" : true,
  "name" : "Wild Child",
  "version" : {
    "number" : "0.19.3",
    "snapshot_build" : false
  },
  "tagline" : "You Know, for Search",
}
Error log:

Code:
XenForo_Exception: Elasticsearch server returned no response. Is it running? Elasticsearch indexing failed for post-565265 - library/XenES/Search/SourceHandler/ElasticSearch.php:721
Generated By: xxxxx, 57 phút trước
Stack Trace
#0 /var/www/html/community/library/XenES/Search/SourceHandler/ElasticSearch.php(748): XenES_Search_SourceHandler_ElasticSearch->_logSearchResponseError(false, false, 'Elasticsearch i...')
#1 /var/www/html/community/library/XenES/Search/SourceHandler/ElasticSearch.php(58): XenES_Search_SourceHandler_ElasticSearch->_assertIndexSuccessful(false, 'post', 565265)
#2 /var/www/html/community/library/XenForo/Search/Indexer.php(44): XenES_Search_SourceHandler_ElasticSearch->insertIntoIndex('post', 565265, '', '[quote="r.e.d, ...', 1339374923, 13473, 42559, Array)
#3 /var/www/html/community/library/XenForo/Search/DataHandler/Post.php(51): XenForo_Search_Indexer->insertIntoIndex('post', 565265, '', '[quote="r.e.d, ...', 1339374923, 13473, 42559, Array)
#4 /var/www/html/community/library/XenForo/Search/DataHandler/Abstract.php(227): XenForo_Search_DataHandler_Post->_insertIntoIndex(Object(XenForo_Search_Indexer), Array, Array)
#5 /var/www/html/community/library/XenForo/DataWriter/DiscussionMessage.php(688): XenForo_Search_DataHandler_Abstract->insertIntoIndex(Object(XenForo_Search_Indexer), Array, Array)
#6 /var/www/html/community/library/XenForo/DataWriter/DiscussionMessage.php(667): XenForo_DataWriter_DiscussionMessage->_insertOrUpdateSearchIndex()
#7 /var/www/html/community/library/XenForo/DataWriter/DiscussionMessage.php(523): XenForo_DataWriter_DiscussionMessage->_indexForSearch()
#8 /var/www/html/community/library/XenForo/DataWriter.php(1385): XenForo_DataWriter_DiscussionMessage->_postSave()
#9 /var/www/html/community/library/XenForo/ControllerPublic/Thread.php(504): XenForo_DataWriter->save()
#10 /var/www/html/community/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_Thread->actionAddReply()
#11 /var/www/html/community/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#12 /var/www/html/community/index.php(13): XenForo_FrontController->run()
#13 {main}