Elasticsearch localhost should not be checking if certificate is self signed

aoeif8puimklv

New member
when installing elasticsearch, now elasticsearch enables https by default and disables http by default. Xenforo should not be checking for if the cert is self signed if elasticsearch is on localhost.

solution: add a argument to check if elastic search is localhost, if true then allow self signed certificate.
 
Last edited by a moderator:
Upvote 0

Jake B.

Well-known member
Realistically it probably shouldn't be checking if the SSL is self signed at all, or have an option to toggle, even if it's not localhost you're probably referencing it with an IP address
 
Top