1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot Reproduce 'Edit' opens wrong post

Discussion in 'Resolved Bug Reports' started by John Bolton, Jan 25, 2011.

  1. John Bolton

    John Bolton Member

    XenForo 1.0.0 Release Candidate 1




    Not encountered before today but I made two consecutive posts to a thread, then wished to edit the second of them. On clicking 'Edit' in the second post......... the first was opened for editing.

    Thinking that I may have made a silly mistake, I cancelled and repeated the process - with the same result!

    I then asked another moderator to try the same but all worked as it should for him.

    This has only occurred once in over 60 posts (we're still at the testing stage)
     
  2. JVCode

    JVCode Well-Known Member

    Can't reproduce, you sure it wasn't the same silly mistake twice? :)
     
  3. John Bolton

    John Bolton Member

    Twice would be possible, ten+ times no!
     
  4. Mike

    Mike XenForo Developer Staff Member

    This isn't something I've seen, and I'm not sure why it would happen. The links definitely load different URLs, and the cache shouldn't be cross-contaminated.

    What browser?
    Is this the first post you're editing on the current page load?
    Did you make both posts with the QR, and not reload the page before editing?
     
  5. John Bolton

    John Bolton Member

    First time I have seen this too.

    Browsers: Safari 5.0.3 (7533.19.4) and Firefox 3.6.13 (Firefox loaded after fault seen, for test purposes)
    Both posted via QR with gap of several minutes and other posts, and edit first attempted without reload but subsequent attempts all after reloads.

    I would rule out a simple cross-contamination because another administrator of the site could not reproduce the problem - it only happens for original poster (me).

    I have just returned to the site after a couple of re-boots and behavior is now as it should be. If it were a problem with my local cache, surely that would not be common to both browsers :confused:

    PS.
    If this is the only reported instance, put it down to "one of those things" But at this stage of product development I thought it worth reporting.
     
  6. Kier

    Kier XenForo Developer Staff Member

    If you see it happen again, now that it seems to be resolved, please post a new bug report with a link to this one and we'll reopen it.
     

Share This Page