1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Awaiting Feedback During import : Undefined index: message_state

Discussion in 'Resolved Bug Reports' started by Weppa333, Sep 13, 2013.

  1. Weppa333

    Weppa333 Active Member

    I am currently doing a large import VB3->XF1.1

    I am unable to move threads that have been imported, XF spills out this error


    Server Error
    Undefined index: message_state

    1. XenForo_Application::handlePhpError() in XenForo/Search/DataHandler/Post.php at line 27
    2. XenForo_Search_DataHandler_Post->_insertIntoIndex() in XenForo/Search/DataHandler/Abstract.php at line 227
    3. XenForo_Search_DataHandler_Abstract->insertIntoIndex() in XenForo/DataWriter/Discussion.php at line 623
    4. XenForo_DataWriter_Discussion->_updateSearchIndexTitle() in XenForo/DataWriter/Discussion.php at line 550
    5. XenForo_DataWriter_Discussion->_indexForSearch() in XenForo/DataWriter/Discussion.php at line 388
    6. XenForo_DataWriter_Discussion->_postSave() in XenForo/DataWriter.php at line 1385
    7. XenForo_DataWriter->save() in XenForo/ControllerPublic/Thread.php at line 772
    8. XenForo_ControllerPublic_Thread->actionSave() in XenForo/FrontController.php at line 313
    9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    10. XenForo_FrontController->run() in /xxxxxxxxxxxx/index.php at line 13

    Is this a known problem ?
    What can I do ?
     
  2. Weppa333

    Weppa333 Active Member

    As this seems to have somth to do with search, I have search disabled, and I'm importing a VB3.
    I can surf on threads, move threads that have been created by XF, but I cannot move threads created by the import
    Probably other things broken but that's the first one :)
     
  3. Weppa333

    Weppa333 Active Member

    I cannot edit the title either, similar error

    Server Error
    Undefined index: message_state
    Undefined index: message_state
    1. XenForo_Application::handlePhpError() in XenForo/Search/DataHandler/Post.php at line 27
    2. XenForo_Search_DataHandler_Post->_insertIntoIndex() in XenForo/Search/DataHandler/Abstract.php at line 227
    3. XenForo_Search_DataHandler_Abstract->insertIntoIndex() in XenForo/DataWriter/Discussion.php at line 623
    4. XenForo_DataWriter_Discussion->_updateSearchIndexTitle() in XenForo/DataWriter/Discussion.php at line 550
    5. XenForo_DataWriter_Discussion->_indexForSearch() in XenForo/DataWriter/Discussion.php at line 388
    6. XenForo_DataWriter_Discussion->_postSave() in XenForo/DataWriter.php at line 1385
    7. XenForo_DataWriter->save() in XenForo/ControllerPublic/Thread.php at line 772
    8. XenForo_ControllerPublic_Thread->actionSave() in XenForo/FrontController.php at line 313
    9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    10. XenForo_FrontController->run() in /dddddd/index.php at line 13
     
    Last edited: Sep 13, 2013
  4. borbole

    borbole Well-Known Member

    try to put in a ticket about this at your customer area.
     
  5. Weppa333

    Weppa333 Active Member

    will do,
     
  6. Mike

    Mike XenForo Developer Staff Member

    Have you rebuilt the thread information? (This is normally done when completing the import.)
     
    Adam Howard likes this.

Share This Page