1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dual emails and emailtemplate bugs

Discussion in 'Troubleshooting and Problems' started by fronix, Dec 7, 2012.

  1. fronix

    fronix Member

    This past months I have had an annoying problem where whenever someone uses something that sends me or anyone else an email, for example someone PM's me or uses contact form, we get more than one email of the same thing. Mostly only two but sometimes there can be up to three or even four emails.

    There is also something wrong with our email templates, emails look broken like such where it says {user_id} and so on.

    Here is a pic of an email:

    I'm not sure if this actually is a bug but better be safe than sorry :)
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That screenshot is the "contact_email_body_text" phrase. The tokens are correct. This might be a problem with the email template and not the phrase. Try visiting /install and click the button to rebuild the master data. That will rebuild the email templates which may fix the problem with unparsed tokens.

    The duplicate emails might just be the result of the user clicking "submit" more than once. This problem is especially common when your forum is being slow for whatever reason. The slow performance can cause users to submit forms multiple times when it doesn't immediately respond.

    Moving to troubleshooting for now...
  3. fronix

    fronix Member

    I will try rebuilding like you said.

    Okay, yes users have been complaining that the forum is slow. Maybe it's time to start using some CDN solution.
  4. fronix

    fronix Member

    The rebuild didn't work, still having that token problem.
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Then try reverting that specific phrase if it's customized. The tokens appear correct, but maybe there is a problem with the phrase itself.
  6. fronix

    fronix Member

    Doesn't seem to be possible to revert it, or at least it doesn't give me an option to do that.
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    If the problem still exists with addons disabled then send me a URL and admin login and I will take a look.

Share This Page