As designed Drafts not available when editing a long post

djbaxter

Well-known member
Affected version
2.2.4
I just discovered this while editing a rather long post (regular Discussion format, not Article, although this may happen with the other formats too).

When composing the post, the drafts button was there as always.

However, I needed to leave my desktop for a while before I had completed the post and I didn't want to lose what I had written so far so I saved the post.

Later, when I went back to edit/finish the post, I had added quite a bit of new text when I accidentally hit something on the keyboard which bounced me to a new window.

I returned to the post to finish editing and discovered that everything I had added during the previous edit was gone and there was no drafts button to recover it.

I'm not using any editor toolbar modifying addons, although I have made some modifications using the Xenforo buttons editor and added a few custom BBcodes with Font Awesome icons.

I may be missing a setting somewhere but I can't find any setting anywhere to enable drafts in edit mode.

I can reproduce this here, as with this post.
 

420

Active member
Might be the same thing I've been experiencing at random.

Without touching anything, the editor rolls back to a previous auto save point, undoing the typing.

When it occurs, you can actually watch it happen.

You post something over something, then about 20 seconds later, it flashes and the new text disappears, displaying the last text typed from the auto save.
 

Mike

XenForo developer
Staff member
At this time, this is generally expected -- drafts are simply not supported anywhere when editing content. This may be something we could try to expose in the future, though it's unlikely to be trivial. It may be best to post this as a suggestion.
 
Top