• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 downloaded 1.5.10 upgrade package and it's trying to do a full install?

sross

Active member
#1
I copied over the files, went to the install directory and it's like it's trying to do a full install, any ideas?

Screen Shot 2016-08-31 at 11.30.50 AM.png

I've never run into this issue before. My downloaded package definitely says it's the upgrade package "_upgrade".

Thanks
 

Mike

XenForo developer
Staff member
#3
The other possibility is that the files weren't "merged". This is somewhat dependent on the FTP application (by not merging, it effectively encourages data loss). If this is the case, then the data and internal_data directories may be missing entirely (along with library/config.php), which is potentially a major problem. If that's really what happened, you may need to restore a backup set of files before redoing the upload ("merging" with the existing files).
 

sross

Active member
#5
hmm ok not the problem since this is on my dev box will restore cpanel backup and investigate. Is there a way to verify i have the upgrade package and not the full install inspite of it ending with _upgrade? I've done a lot of these upgrades, never came across this yet. Thanks
 

Mike

XenForo developer
Staff member
#6
The upgrade package only has minor differences -- notably, it doesn't include data/, internal_data/ or .htaccess. But those are essentially the only differences.
 

sross

Active member
#7
ok, tried running the upgrade again and it's still attempting to do a full install. According to this:

3. I am trying to upgrade but it is attempting to do a new installation, how do I proceed without overwriting the existing data?
It's possible you have uploaded the files from the full package, rather than the upgrade package. Or you have uploaded the correct files but to the wrong location. Check that your data and internal_data directories have not been overwritten. If they have, you will need to restore the files from a backup. To continue with the upgrade, you will need to ensure the correct details are in library/config.php and replace the internal_data/install-lock.php file.
upgrade package verified
location fine
data and internal data exist

the last bit "To continue with the upgrade, you will need to ensure the correct details are in library/config.php and replace the internal_data/install-lock.php file."

not sure I follow but it seems to be a step after you restore data and internal_data which I don't need to do.

Could this be happening because I'm on a dev server which has htaccess lock or something like that?

Thanks
 

sross

Active member
#9
ok, the config is now config.php.default which is odd but the lock file still exists, guess I just have to restore the config.php
 

Mike

XenForo developer
Staff member
#10
Correct. If you had any add-ons installed, it's quite likely that their files within library/ have been removed as well.
 

sross

Active member
#11
Correct. If you had any add-ons installed, it's quite likely that their files within library/ have been removed as well.
Any idea how this happened when it's just an upgrade package? What can I do in the future to ensure this doesn't happen again? Thanks
 

sross

Active member
#12
ok i think i see what happened. It's my Mac ftp app "Transmit" by default it is overwriting the folder. For anyone else with a similar issue:

1) Open Transmit and from the file menu - click on Transmit -> Preferences -> Transfers

You will see that for Uploading folders it has the following options:

- Ask me what to do
- Replace the existing folder
- Merge the existing folder
- Skip the folder

2) Next to "Uploading folders" choose the Merge the existing folder option

3) Close the preferences