• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Browser issue Double digit when copy-paste to the editor - RTL

Moshe1010

Well-known member
#1
Hi,

It looks like XF+Chrome has a weird issue in which copy-pasting a text duplicates a digit in the first number that appears in the text. Here is a gif that represents what I'm talking about:

https://www.dropbox.com/s/14lsd4unjhr7ow8/33322.gif?dl=0

If you for example try to copy-paste the following text to the editor in XF, it would duplicate the number "8":
https://www.kilogram.co.il/221

Search for the term "Stanozolol" in the above article and copy-paste the paragraph in Hebrew that belows. Try to paste it to the editor in the forum and it would duplicate the 1988 several times (it would create "19888").

Now when you copy-paste it in the BB Code editor it works fine. With Firefox it works fine in either editor.I couldn't replicate the same issue on other websites, so I'm wondering if it's a Chrome bug or XF bug.

Thanks.
 

Mike

XenForo developer
Staff member
#2
Unfortunately, this looks like a browser issue. This appears to be what's in the pasted HTML that we see. (I'm also seeing it in XF2 which I believe is using a different method for extracting the HTML -- one that's even lower level -- so it must be what the browser is seeing.
 

Moshe1010

Well-known member
#3
Unfortunately, this looks like a browser issue. This appears to be what's in the pasted HTML that we see. (I'm also seeing it in XF2 which I believe is using a different method for extracting the HTML -- one that's even lower level -- so it must be what the browser is seeing.
Is there a way to reproduce it in order to report google/chrome on this issue?
 
Last edited:

Chris D

XenForo developer
Staff member
#6
If you don't mind doing it, that'd be great.

By all means please link them to the jsfiddle I created above.