1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Discussion in Resource Overview by Waindigo [Deleted]

Discussion in 'Add-on Releases' started by Jon W, Oct 17, 2013.

  1. Jon W

    Jon W Well-Known Member

    Waindigo submitted a new resource:

    Discussion in Resource Overview by Waindigo - Add-on for Resource Manager, moves the discussion from its own tab to be underneath the overview.

    Read more about this resource...
    Last edited: Nov 20, 2013
    Digital Doctor and SignTorch like this.
  2. CFodder

    CFodder Well-Known Member

    Which version of the RM is this compatible with?

    Only ask as I tried it on our dev board, below the resource it showed updates and then the full set of tabs again with the discussion tab added.

    Using XF 1.2.2 with RM 1.0.0

    Picture's worth a thousand words so here's a pic of it :):

    Last edited: Oct 18, 2013
  3. SignTorch

    SignTorch Active Member

    I love this, I didn't like the way resource thread lists went to the discussion tab

    I had to disable @Nobita Threads And Messages Per Page Preferences addon because it caused resource thread links to go to the discussion tab, and then that tab would disappear upon clicking on the overview tab, so that addon somehow circumvented this addon's redirection feature
  4. Jon W

    Jon W Well-Known Member

    I assume you mean @Nobita.Kun. The conflict is with both add-ons extending the route prefix (the bit of code that builds links to threads). I will see if I can work around this, although might not be possible.
  5. SignTorch

    SignTorch Active Member

    yes, I mainly just mentioned it in case anyone else ran into it, I know you're busy so this can wait as far as I'm concerned.
  6. TSPowerr

    TSPowerr Member

    Great addon but i noticed that its not compatible with xfRM+. When there are both enabled, your plugin doesnt work. Nothing important, i just disabled xfRM.
    Last edited: Nov 15, 2013
  7. Jon W

    Jon W Well-Known Member

    What is xfRM+?
  8. Bram

    Bram Well-Known Member

    If the discussion is moved to the resource itself (fantastic btw) will it still be accessible as a forum thread as well?
  9. Jon W

    Jon W Well-Known Member

    The link to the threads will still be there in the respective forums, but the link will point to the resource. If you want different functionality than this, please drop me a PM as it will only be a small cost to change this.
    Bram likes this.
  10. BassMan

    BassMan Well-Known Member

  11. Chris D

    Chris D XenForo Developer Staff Member

    I will test this later. But can you be specific about what happens when they are all installed together?
  12. BassMan

    BassMan Well-Known Member

    Check convo for screens.
  13. Chris D

    Chris D XenForo Developer Staff Member

    For anyone who is wondering, the two screenshots I have received show a severely distorted display compared to a normal display. The normal display appears to have one or both of my add-ons disabled.

    On the distorted display, a lot of the CSS and HTML is broken.

    Here is my screenshot from my dev board with Waindigo's add-on enabled and both my add-ons:


    It's actually working fine (apart from the Share This Page block but that might be one for @Waindigo to look into as it's caused by the thread_view share_page.css I believe).

    So @BassMan you should try this on an unedited, default style. If the problem only exists in your custom style, you should consult with the style author.
    Digital Doctor and Jon W like this.
  14. Jon W

    Jon W Well-Known Member

    Chris D likes this.
  15. Jon W

    Jon W Well-Known Member

    Thanks for testing this out Chris. I hadn't even noticed the Share Page appearing twice (and messing up in the sidebar). This is now fixed.

    Unfortunately, this add-on, due to its nature (i.e., merging two different pages into one), is more likely than most to cause CSS issues with some styles. A good style designer should be able to fix any problems you are having though without too much difficulty.
    Chris D likes this.
  16. BassMan

    BassMan Well-Known Member

    @Chris Deeming, actually I'm using the default Xenforo style, but have some add-ons. What exactly could be wrong?

    And after last Waindigo's update (1.0.1) I can use your add-on Resource Watchers, but when I activate Thread watchers it brakes again. Well, at least one add-on can be enabled on my site now.
  17. Jon W

    Jon W Well-Known Member

    Can you post the screenshot here please?
  18. BassMan

    BassMan Well-Known Member

    Btw, I've edited my last post...

    Check convo for screens...
  19. BassMan

    BassMan Well-Known Member

    Actually, I can use only one of those add-ons. So, Resource Watchers OR Thread Watchers, but not both of them!
  20. Chris D

    Chris D XenForo Developer Staff Member

    I suspect it is another add-on causing the issue.

    Leave the three add-ons disabled and disable your others one by one. I suspect one of the other add-ons being disabled will solve the issue.

Share This Page