• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Disallowed email even though its the same

#1
Annoying issue I've been trying to fix all day, my "sender" name is the same as my email and the same used in "Default Email Sender Name". This is the most asinine error I've ever encountered...




Code:
Email to example@gmail.com failed: Relaying disallowed as MyCommunity <noreply@mycommunity>
 

Mike

XenForo developer
Staff member
#2
I assume you're sending via SMTP. This will be an error message from your SMTP server, so really you'll need to ask your SMTP provider about their restrictions. I would guess that your from address or your bounce address are different than what you're using to log into your SMTP server and they won't let you send from different addresses that what you authenticate with.
 
#3
Last time I set this up with a different domain, I did no further configuration, now I get this error. Email/credentials are the same.

They said:

When the email address (or login credentials) you have provided in the application does not match the email address (or credentials) of your account's outgoing server, you will see a 'Relaying Disallowed' error when you attempt to send an email. The SMTP client will not be able to send the email because of the email address mismatch.

This can happen when an email address is used as default in a coded program or when you have misspelled the email address while configuring your email inbox. You will receive emails without any issues. To resolve the 'Relaying Disallowed' error, you need to correct the email address provided.
Do you think this could be it; This can happen when an email address is used as default in a coded program.

//EDIT
I also get this error occasionally.

ErrorException: fwrite(): SSL operation failed with code 1. OpenSSL Error messages: error:140D00CF:SSL routines:SSL_write:protocol is shutdown - library/Zend/Mail/Protocol/Abstract.php:324
 
Last edited:
#5
The problem is back it seems.. now even weirder. It works sending users password resets, but no one requests password resets or anything of the sort! It just keeps generating these errors!!! my server log is full of them.

Code:
Zend_Mail_Protocol_Exception: Email to example@gmail.com failed (after retry): Relaying disallowed as myboard <noreply@myboard> - library/Zend/Mail/Protocol/Abstract.php:431

Code:
ErrorException: fwrite(): SSL operation failed with code 1. OpenSSL Error messages: error:140D00CF:SSL routines:SSL_write:protocol is shutdown - library/Zend/Mail/Protocol/Abstract.php:324
 

Mike

XenForo developer
Staff member
#6
The first is still the same issue as before. To confirm though, what's the stack trace on this error?

The latter is generally indicating that the connection to the SMTP server was forcibly closed. That's more of a general networking error, though it may end up being paired with another error that's happening.
 

Mike

XenForo developer
Staff member
#8
The stack trace is the section below the error itself when you click on an entry in the server error logs.