RM 2.0 "dfe_album_id" error is driving my nuts!!!

Jordyn

Formerly EvilSS
Hi,
No matter what i disable or how much i try to fix this stupid error, nothing seems to work or fix it!
I disable all addons still no go, i upload to the latest versions of 2.0 and still get this same error, its driving me nuts.
Everything else is fine apart from this error in RM. I reckon i have tried everything over the last 2 weeks.
Is there away around this error please???

RM does not let me create a thread, when i hit submit, bang!!! Below error.

Server error logXF\Db\Exception: MySQL query error [1364]: Field 'dfe_album_id' doesn't have a default value src/XF/Db/AbstractStatement.php:212

Stack trace

INSERT INTO xf_rm_resource (`resource_category_id`, user_id, username, resource_state, title, tag_line, external_url, alt_support_url, resource_type, rating_weighted, rating_avg, sv_prefix_ids, prefix_id, resource_id, resource_date, current_version_id, description_update_id, discussion_thread_id, external_purchase_url, price, currency, download_count, rating_count, rating_sum, update_count, review_count, last_update, custom_fields, icon_date, tags) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
------------

#0 src/XF/Db/Mysqli/Statement.php(196): XF\Db\AbstractStatement->getException('MySQL query err...', 1364, 'HY000')
#1 src/XF/Db/Mysqli/Statement.php(77): XF\Db\Mysqli\Statement->getException('MySQL query err...', 1364, 'HY000')
#2 src/XF/Db/AbstractAdapter.php(79): XF\Db\Mysqli\Statement->execute()
#3 src/XF/Db/AbstractAdapter.php(160): XF\Db\AbstractAdapter->query('INSERT INTO `x...', Array)
#4 src/XF/Mvc/Entity/Entity.php(1409): XF\Db\AbstractAdapter->insert('xf_rm_resource', Array, false)
#5 src/XF/Mvc/Entity/Entity.php(1141): XF\Mvc\Entity\Entity->_saveToSource()
#6 src/addons/XFRM/Service/ResourceItem/Create.php(288): XF\Mvc\Entity\Entity->save(true, false)
#7 src/XF/Service/ValidateAndSavableTrait.php(40): XFRM\Service\ResourceItem\Create->_save()
#8 src/addons/XFRM/Pub/Controller/Category.php(269): XFRM\Service\ResourceItem\Create->save()
#9 src/addons/SV/MultiPrefix/XFRM/Pub/Controller/Category.php(62): XFRM\Pub\Controller\Category->actionAdd(Object(XF\Mvc\ParameterBag))
#10 src/XF/Mvc/Dispatcher.php(249): SV\MultiPrefix\XFRM\Pub\Controller\Category->actionAdd(Object(XF\Mvc\ParameterBag))
#11 src/XF/Mvc/Dispatcher.php(88): XF\Mvc\Dispatcher->dispatchClass('XFRM:Category', 'Add', 'json', Object(XF\Mvc\ParameterBag), 'xfrm', Object(SV\MultiPrefix\XFRM\Pub\Controller\Category), NULL)
#12 src/XF/Mvc/Dispatcher.php(41): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#13 src/XF/App.php(1934): XF\Mvc\Dispatcher->run()
#14 src/XF.php(333): XF\App->run()
#15 index.php(13): XF::runApp('XF\\Pub\\App')
#16 {main}

array(4) {
["url"] => string(47) "/index.php?resources/categories/downloads.2/add"
["referrer"] => string(64) "https://test22.com/index.php?resources/categories/downloads.2/add"
["_GET"] => array(1) {
["resources/categories/downloads_2/add"] => string(0) ""
}
["_POST"] => array(17) {
["title"] => string(9) "hi up poo"
["tag_line"] => string(15) "this is nothing"
["resource_type"] => string(14) "download_local"
["version_attachment_hash"] => string(32) "474b0511348dd3f77028c5f86e39c32c"
["version_attachment_hash_combined"] => string(106) "{"type":"resource_version","context":{"resource_category_id":2},"hash":"474b0511348dd3f77028c5f86e39c32c"}"
["version_string"] => string(0) ""
["description_html"] => string(34) "<p>complete test till 1 2 3 4.</p>"
["attachment_hash"] => string(32) "4f07b86d6dca0b866d68ed0e319bb328"
["attachment_hash_combined"] => string(105) "{"type":"resource_update","context":{"resource_category_id":2},"hash":"4f07b86d6dca0b866d68ed0e319bb328"}"
["tags"] => string(0) ""
["external_url"] => string(0) ""
["alt_support_url"] => string(0) ""
["icon_action"] => string(6) "custom"
["_xfToken"] => string(8) "****"
["_xfRequestUri"] => string(47) "/index.php?resources/categories/downloads.2/add"
["_xfWithData"] => string(1) "1"
["_xfResponseType"] => string(4) "json"
}
}
 

Mike

XenForo developer
Staff member
This is actually likely to be caused by a disabled add-on that hasn't specified it's database changes correctly. You'd really need to contact the add-on author for guidance, as they need to change the column to have a default value. Hopefully "dfe_album_id" makes it clear which add-on it relates to.

In theory, it could be related to an uninstalled add-on, though that would add a whole extra bug to it and hopefully the add-on cleans itself up on uninstallation.
 

Jordyn

Formerly EvilSS
Thanks man. But its not a XF2 addon causing this. Well from what i have tested anyway. I am slowing uninstalling all the old XF1.5 addons just to see also. I thought the "dfe" mite give me a indication of what addon it could be, but just cant figure it out. MultiPrefix is ruled out fromerror log. Disabling .htaccess was my last option before creating this thread. Thanks for the reply mate, theres no disabled addons, but i'll keep trying.
 

Jordyn

Formerly EvilSS
You were correct @Mike, i decided to download the sites sql file and find dfe_album_id, which i could not find in phpmyadmin. I seen there was a dfe table under CREATE TABLE xf_resource. So i went back into phpmyadmin and looked in xf_rm_resource, clicked Table structure and sure enough, there is was. I did a back up and dropped the dfe_album_id table, and bang, my XFRM works fine now after weeks of searching for the cause of the above error. Thank you so much Mike, i almost went back to XF1.5. There was no other traces of the mod apart from that 1 table!

I recommend anyone using dfe gallery to remove all traces before upgrading to XF2. After the upgrade to XF2, it was this mod that left 1 table in RM: https://xenforo.com/community/resources/dfe-resource-gallery.5210/

I can finally move on! Thanks.
Hope @AlexL777 fixed his same issue, if not, hears the fix above mate.
 

Brogan

XenForo moderator
Staff member
Any issues with the add-on should be reported in the discussion thread.

The author can then look at updating it to ensure all data is removed when uninstalling.
 
Top