1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Default Prefix bug

Discussion in 'Resolved Bug Reports' started by gldtn, Oct 6, 2011.

  1. gldtn

    gldtn Well-Known Member

    After adding some prefix and setting it to selected forums, when going to a forum and trying to set a default prefix, it disables the prefixes on that forum, not letting you set a default.
  2. John L.

    John L. Well-Known Member

    I can confirm this also happens on my test server as well.
    gldtn likes this.
  3. bambua

    bambua Well-Known Member

    Confirmed on mine as well, was just going to post this as a bug.
    gldtn likes this.
  4. kkm323

    kkm323 Well-Known Member

    XF team so tired. Yesterday was a very busy day..
    they are probably sleeping now :sleep:
  5. ragtek

    ragtek Guest

    Additional Info:

    It's also not possible to set prefixes in the forum editor.

    Steps to reproduce:

    create a forum, go to edit form, rename the forum, change some options & add a thread prefix.

    ALL infos are stored, only thread prefix not

    html sourcecode
    <ul id="AvailablePrefixes">
    <li><label for="ctrl__1"><input type="checkbox" id="ctrl__1" value="1" name="[]"> Benutzer beobachten</label></li>

    Attached Files:

    • foo.png
      File size:
      22.8 KB
  6. Kier

    Kier XenForo Developer Staff Member

    Well that's odd...
  7. Kier

    Kier XenForo Developer Staff Member

    Found it.

    If you want to fix it yourself, edit the admin template forum_edit and change the following code:
    <xen:option value="{$prefixId}" selected="in_array({$prefixId}, {$nodePrefixes})">{$title}</xen:option>
    to this
    <xen:option name="available_prefixes[]" value="{$prefixId}" selected="in_array({$prefixId}, {$nodePrefixes})">{$title}</xen:option>
    RvG, gldtn and bambua like this.
  8. bambua

    bambua Well-Known Member

    That did it, worked brilliantly. Thanks Kier
    gldtn likes this.

Share This Page