• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Default avatar not showing up for new members

Jeff Fuqua

Well-known member
#3
Thanks for the reply.

I go into the data folder and following it to 131xx.jpg but there isn't a ? with numbers after it.

Are you saying this member uploaded an avatar that didn't work? I had to delete it through his admin page in order to restore it to the default.
 

Jeremy

Well-known member
#4
The ?# is a cache buster and forces a browser to recognize it as a new image, you won't see that in the server. So 13156.jpg does exist?
 

Brogan

XenForo moderator
Staff member
#6
Deleting the file from the server in that manner won't resolve the issue.

Edit the member in the ACP if you want to remove an avatar.
 

Brogan

XenForo moderator
Staff member
#8
Then the images have been removed for some reason.

Have you done a server move or upgrade recently?

Did you overwrite the folders or delete them?

We can't access those links as guests by the way.
 

Jeff Fuqua

Well-known member
#11
Sorry to bring this up again but I'm trying to track down the issue.

I just created a new test member account. I went in and tried to upload a 192 x 192 png and jpg avatar. In both instances, I get a broken link icon.

If I click on the broken icon and open it in a new browser tab, I get a 404 error.
http://www.gotitans.com/data/avatars/m/13/13204.jpg

When looking in the folder via FTP, no image is there so it appears as if the upload is not functioning properly. When I put it into the folder manually, it works fine.

Any ideas? Thanks.
 

Mike

XenForo developer
Staff member
#12
It could be a permission issue, though you should get an error regarding that -- check the error log in the control panel.

If there's nothing there, the only thing I could think of is something manipulating the file system unexpectedly.
 

Mike

XenForo developer
Staff member
#14
I suspect that's only caused by the file not being there. I would check the permissions for your data/ and internal_data/ directories and all files/directories within them (recursively). I would normally recommend that you make these world readable/writeable (0777).