• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Database Error without additional error info in the HTML Source?

XFuser

Active member
#1
Hello,

Our site is showing the following error:
Code:
An unexpected database error occurred. Please try again later.
When viewing the source, this is all we see:
Code:
<html><head></head><body>An unexpected database error occurred. Please try again later.
 </body></html>
So there is no additional information about this Database error in the HTML source.

It happened suddenly out of the blue. Site has been working fine for months.

How can we diagnose this Database error?

Thank you.
 

Brogan

XenForo moderator
Staff member
#2
If it happened suddenly with no changes made by you, then contacting your host is likely the best course of action, as it suggest something has changed on the server.

The site is actually working for me right now.
 

XFuser

Active member
#3
If it happened suddenly with no changes made by you, then contacting your host is likely the best course of action, as it suggest something has changed on the server.

The site is actually working for me right now.
We're waiting to hear back from them although they seem to have fixed it.

For future reference, is there any way to diagnose on our end a Database Error that doesn't contain additional error info in the HTML source? Also, what type of Database Errors don't provide additional error info in the HTML source?

No part of XF seemed to be accessible during this issue, not even the Admin panel (and there aren't any Server errors in the log now that it's accessible).
 

Brogan

XenForo moderator
Staff member
#4
Unless there is additional information in the source, the only other way of possibly determining the cause would be by inspecting the server error logs, which may have more information.
 

Mike

XenForo developer
Staff member
#5
Based on the code, there's no way to get this error without more details in the source. The only thing I could think of is something outside XF stripping out the comments. Looking at the source of your site now, this seems likely.