Server issue  Database error when trying to start a conversation

Umit

Active member
Hi,

imported from vb3.7.0 to xf rc2

everything looks fine but cant start a conversation,
when i try, i get this message:

An unexpected database error occurred. Please try again later.
<!-- mysqli prepare error: MYSQL server gone away -->

i can reply to conversations tho...
and another strange things is other members can start a conversation.
 

Shamil

Well-known member
this is not a XenForo bug, I'd imagine.

The most common reason for the MySQL server has gone away error

1. Is that the server timed out and closed the connection. By default, the server closes the connection after 8 hours or 28800 seconds if nothing has happened. You can change the time limit by setting the wait_timeout variable when you start mysqld via your server's /etc/my.cnf as well.

2. Another common reason to receive the MySQL server has gone away error is because you have issued a ``close'' on your MySQL connection and then tried to run a query on the closed connection. You can check that the MySQL hasn't died by executing mysqladmin version and examining the uptime.
http://dev.mysql.com/doc/refman/5.1/en/gone-away.html
 

Umit

Active member
Note: i had enabled email transport method to smtp (entered google apps mail settings),
I've just changed it to "default" option and no any more database error.
 

Shamil

Well-known member
Note: i had enabled email transport method to smtp (entered google apps mail settings),
I've just changed it to "default" option and no any more database error.
Were you constantly getting the error before that change?
 

Shamil

Well-known member
yes, when it was set to SMTP,
but the strangest thing is other members was sending without error.
Might be something related to the import.

I am unable to reproduce this on the latest, RC2, stock default, SMTP (->Google Mail) development environment.
 

Mike

XenForo developer
Staff member
That sounds like the SMTP call was taking a long time, triggering MySQL's wait_timeout due to inactivity. Unfortunately, there's not really much we can do about it.
 

Umit

Active member
That sounds like the SMTP call was taking a long time, triggering MySQL's wait_timeout due to inactivity. Unfortunately, there's not really much we can do about it.
Hi Mike,

to solve this problem, can i do something? i really want to use smtp mail.
 
Top