[cXF] Conversation Button under Avatar

[cXF] Conversation Button under Avatar 2.7.4

No permission to download

BassMan

Well-known member
BassMan updated Conversation Button under Avatar with a new update entry:

2.2.0

What's new in version 2.2.0:
  • added user group premissions
View attachment 93143


Check permissions under Personal Conversations Permissions for each user group:​
    • set Start personal conversations to Allow to enable (default Xenforo) conversations for user group
    • set Conversation Button under Avatar to Allow to enable add-on functionalities for selected user group
    ...

Read the rest of this update entry...
 

tonnyz

Member
BassMan updated Conversation Button under Avatar with a new update entry:

2.2.0

Hi @BassMan , sorry for bothering you, but I found some things about this add-on :

1. "upload" button and "preview" button (https://xenforo.com/community/resources/quick-reply-preview.756/) is missing either in the overlay or in the full page of conversation_add when add-on is permitted on specific usergroup. (happened in all styles)

2. overlay of conversation_add is currently set as fixed position in non-mobile width. It'll cause a problem when editor is shown coz the button will be pushed below the sceen and can't be clicked for the fixed position. (happened in all styles)

3. "Show as button in staff online block" does not show any button in staff online block when it's checked (happened in all styles)

4. "Show as icon in staff online block" does not show any icon in staff online block when it's checked (happened in all styles)

5. "Show on member card" still does not show any button in member card when it's checked , although the default "start a conversation" link has been hidden from the member card. (happened only in Flat Awesome style)

6. " Redirect function" is a cool option, but I think it'll be much better to exclude this option from affecting the full page of conversation_add.
IMHO, it does make sense for not redirecting after sending conversation from the button in overlay, but it does not for sending from the full page.
(happened in all styles)

thx for your help :)

PS: I'm currently using XenForo 1.3.3
 

BassMan

Well-known member
Hi tonnyz!

1. "upload" button and "preview" button (https://xenforo.com/community/resources/quick-reply-preview.756/) is missing either in the overlay or in the full page of conversation_add when add-on is permitted on specific usergroup. (happened in all styles)
Check FAQ tab.

2. overlay of conversation_add is currently set as fixed position in non-mobile width. It'll cause a problem when editor is shown coz the button will be pushed below the sceen and can't be clicked for the fixed position. (happened in all styles)
Not sure about that. Can not reproduce this.

3. "Show as button in staff online block" does not show any button in staff online block when it's checked (happened in all styles)

4. "Show as icon in staff online block" does not show any icon in staff online block when it's checked (happened in all styles)
Tested and works fine. Check permissions and set Conversation Button under Avatar to Allow. If it will not work, check your template modifications for this add-on (check if there are any gray or red numbers).


5. "Show on member card" still does not show any button in member card when it's checked , although the default "start a conversation" link has been hidden from the member card. (happened only in Flat Awesome style)
Works fine on my side:
upload_2015-1-10_19-32-18.png

Check things I've said under previous quote.


6. " Redirect function" is a cool option, but I think it'll be much better to exclude this option from affecting the full page of conversation_add.
IMHO, it does make sense for not redirecting after sending conversation from the button in overlay, but it does not for sending from the full page.
(happened in all styles)
Check FAQ. There are some limitations and on admin to decide what is more important for his forum.

Btw, I'm testing on 1.4.3 now.
 

tonnyz

Member
Hi tonnyz!


Check FAQ tab.


Not sure about that. Can not reproduce this.


Tested and works fine. Check permissions and set Conversation Button under Avatar to Allow. If it will not work, check your template modifications for this add-on (check if there are any gray or red numbers).



Works fine on my side:
View attachment 94390

Check things I've said under previous quote.



Check FAQ. There are some limitations and on admin to decide what is more important for his forum.

Btw, I'm testing on 1.4.3 now.

Regarding the "redirect", "preview button" and "upload button", is there absolutely no turnaround way to differ the behaviour between those on overlay with those on the static page ?

About the others, I'll try it soon on XF 1.4.3, thx for your response :)
 

BassMan

Well-known member
Regarding the "redirect", "preview button" and "upload button", is there absolutely no turnaround way to differ the behaviour between those on overlay with those on the static page ?
In this state (this add-on is based on template modifications) I don't think so. Sorry.
 

BassMan

Well-known member
BassMan updated Conversation Button under Avatar with a new update entry:

2.3.0

What's new in version 2.3.0:
  • option to enable Font Awesome icons locally
  • disable Font Awesome script if you don't use FA icons
  • new add-on icon
Check the main style properties group for this add-on to enable/disable Font Awesome icons.


How to upgrade:
  • Copy content in 'upload' folder to right directory on server
  • Go to your Admin Control Panel and click "Install Add-on" link
  • Upload the xml file and click the...

Read the rest of this update entry...
 

audiokid

Active member
I have a suggestion,

I have a lot of Guests.
They are the results of removed usernames over the last 15 years. The Conversation Icon on the Avatar location is showing up there. If you click onto the conversation link, it goes into a page error.

other that that, nice job!
guest.PNG
 

Attachments

  • guest-2.PNG
    guest-2.PNG
    70.4 KB · Views: 5
Top