1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Custom user field not showing on posts

Discussion in 'Troubleshooting and Problems' started by Solidus, Sep 4, 2015.

  1. Solidus

    Solidus Well-Known Member

    Hey all.

    What would cause a custom user field not to show up on posts? I have the option checked in message elements and it does display for other users. It's just myself (and maybe another admin) that it doesn't work for.
    Is there an option I've missed somewhere?

    Thanks.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    These are the relevant settings:

    Admin CP -> Users -> Custom User Fields
    > General Options: Viewable in message user info


    Admin CP -> Appearance -> Style Properties -> Message Elements -> Show custom user fields

    Try a default style? Disable addons?
     
    michael24179 likes this.
  3. Solidus

    Solidus Well-Known Member

    Default style and disabling addons did not fix. Custom fields still displayed for everyone else.
     
  4. Mike

    Mike XenForo Developer Staff Member

    Try changing the value in the field. Is it any different?
     
    Solidus likes this.
  5. Solidus

    Solidus Well-Known Member

    Yes. I changed it to display in Personal Details and now it shows. Before it was in Contact Details, and I'd like to keep it that way.
     
  6. Mike

    Mike XenForo Developer Staff Member

    I was referring to editing your profile. You said it was specific to you.

    That said, with this extra detail, it's down to your "View your identities" privacy setting. Only people that display them publicly will have the value shown with the post.
     
    Solidus likes this.
  7. Solidus

    Solidus Well-Known Member

    That's the one! Thanks a bunch, Mike.
     

Share This Page