1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Custom seo-titles for subforums

Discussion in 'Styling and Customization Questions' started by sdev, Feb 24, 2015.

  1. sdev

    sdev Member

  2. Brogan

    Brogan XenForo Moderator Staff Member

    Which title/page view are you referring to?

    The title for each node is set in the ACP.
  3. sdev

    sdev Member

  4. sdev

    sdev Member

    In vBulletin 3 this works, I'm looking for something like:

    <xen:if is="{$forumID} == 3">
  5. sdev

    sdev Member

    Found it <removed>

    <xen:if is="{$forum.node_id} == x">
    This content will show in forum x

    or using this

    in_array({$thread.node_id}, array(y, z))
    Last edited by a moderator: Oct 22, 2015
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Amaury likes this.
  7. sdev

    sdev Member

    This didnt work, when editing PAGE_CONTAINER all threads also changed title plus forum.

    Anyone know how to fix this? Something like this maybe
    <xen:if is="{$forum.node_id} == 2 and {$contentTemplate} == 'xyz'">
    This content will show on the xyz template and id 2
  8. sdev

    sdev Member

    Solved it again... :)

    <xen:if is="{$contentTemplate} == 'forum_view'">

    <xen:if is="{$forum.node_id} == 2">
  9. sdev

    sdev Member

    This stopped working in XF 1.5.

      <xen:if is="{$thread.thread_id} == 30">
       <xen:else />
         <title><xen:if is="{$title}">{xen:raw $title} | {$xenOptions.boardTitle}<xen:else />{$xenOptions.boardTitle}</xen:if></title>
    thread id 30 shows the standard title, not my custom one. Any idea why?

Share This Page