1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue cursor down / does not move beyond image

Discussion in 'Resolved Bug Reports' started by erich37, Jun 13, 2013.

  1. erich37

    erich37 Well-Known Member


    1) write some text into the editor.
    2) drag & drop an image into the editor (underneath the written text)
    3) write some text into the editor (underneath the image)
    4) now use the keys on your keyboard "cursor up" and "cursor down" and move up and down within the editor.

    the key "cursor down" (use your keybord) does not move beyond the link-text of the embedded image.
    the key "cursor right" is working fine and lets you move to the end of the written text at the very bottom of the editor.

    Windows8 / Firefox 21.0

    Last edited: Jun 13, 2013
  2. Mike

    Mike XenForo Developer Staff Member

    I can't reproduce this, but the steps aren't especially clear. Can you show a screenshot that shows what the message looks like and where the cursor is when you can't press down?

    That said, cursor management is completely handled by the browser so it's unlikely that anything will change.
  3. Hornstar

    Hornstar Well-Known Member

    Working fine for me on Windows 7 Firefox 21
  4. erich37

    erich37 Well-Known Member

    see attached:

    I used "Google image search" and search for an image with the search word "sun".
    Drag & Drop any "sun image" directly from the "Google image search results" into the editor.
    It automatically also displays the "Link-Source-URL" from the image, which is fine.
    But when using the key "cursor down" on your keyboard", then the cursor stops at the very end of the automatically embedded "Link-Source-URL".
    The cursor does not move to the text I have written at the very bottom within the editor.
    When using "cursor right" button on the keyboard, then the cursor is behaving fine and moves to the very bottom text. But button "cursor bottom" on my keyboard stops at the end of the embedded "Link-Source-URL".

    Last edited: Jun 14, 2013
  5. Hornstar

    Hornstar Well-Known Member

    Confirmed with the above steps.
    erich37 likes this.
  6. erich37

    erich37 Well-Known Member

    one more thing:

    if you are at the text at the very bottom, then using key "left cursor" on your keyboard in order to move up...... then the cursor does not move to the very top (to the text I have written atop the embedded image).
    The cursor is stuck at the left-hand-side of the "Link-Source-URL" of the image.

    It seems either the "Link-Source-URL" or "images" in general are somehow blocking certain cursors to move......

    Last edited: Jun 15, 2013
  7. Mike

    Mike XenForo Developer Staff Member

    I'm not totally sure why this happens, though it seems to happen in 1.1 for me as well. We don't really intercept the cursor movements, so I'm just going to tag this as a browser issue.
  8. erich37

    erich37 Well-Known Member

    is this related to FireFox only or does it also happen in other browsers ?
  9. Mike

    Mike XenForo Developer Staff Member

    FF only.

Share This Page