1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 CSS help, need white background in prefix selector

Discussion in 'Styling and Customization Questions' started by HenrikHansen, Jun 29, 2014.

  1. HenrikHansen

    HenrikHansen Well-Known Member

    Due to various CSS modifications my background in the prefex selection box have become transparent.

    Can anyone help with code to make it white?

    Skærmbillede 2014-06-29 kl. 02.22.16.png
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    I'd be slightly concerned as to why it has gone missing, because the background is provided by the secondaryContent class which is one of the core CSS classes that is used pretty much everywhere. Are you sure that's the only place which is affected?

    Aside from that, to fix specifically that area, something like:

    Code:
    .PrefixMenu.secondaryContent
    {
        background: @primaryLightest url('@imagePath/xenforo/gradients/category-23px-light.png');
    }
    That should return it to how it is designed in the default style...

    If you want something more primitive:

    Code:
    .PrefixMenu.secondaryContent
    {
        background-color: white;
    }
     
  3. HenrikHansen

    HenrikHansen Well-Known Member

    Thanks, Chris, for helping me, again :D.
    You are right, this is not the only place affected, also search box and a couple of other places, but that have been solved. Probably happened because I have made style changes for secondary content to make the right column look like I want it to.
     

Share This Page