• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

cron jobs not workin as job.php is on http

Marcus

Well-known member
#1
Code:
From Browser Console Log
Mixed Content: The page at '/' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http:/xxx/job.php'. This request has been blocked; the content must be served over HTTPS.
 

Marcus

Well-known member
#3
If I enable this setting, my site is unable to deliver content
Code:
[LIST]
[*]Enable board URL canonicalization
[/LIST]
If enabled, the board URL setting will be treated as the canonical installation URL. If visitors access your site through a different URL, they will be redirected to the appropriate canonical URL. When enabled, you must ensure that your board URL setting is correct. If it is not correct, areas outside the admin control panel will not be accessible!
The board URL setting is set above this option to https://www.domain.com
 

Mike

XenForo developer
Staff member
#5
That won't affect anything with how the page itself is output. It will just 301 to the correct base URL if it detects it's different.

However, I suspect the issue may be related because I can see the URL is being detected incorrectly. How are you doing SSL? Is it just a reverse proxy and your site isn't actually served via HTTPS? Did you use HTTPS with XF1?
 

Mike

XenForo developer
Staff member
#7
Can you to go <url>/admin.php?tools/phpinfo (via HTTPS) and search for _SERVER[ and then paste/send me the values for all of those entries? There will be some somewhat private details in there, so please send the details to me in a conversation. I want to check what details there are to confirm that the request should be sent over HTTPS.
 

Marcus

Well-known member
#8
1. This solves it in config.php

Code:
$_SERVER['REQUEST_SCHEME'] = 'https';
The request_scheme is set to "http", as my server communicates by http. But my users connect to the server over the CDN by https, so xf uses the internal server data to produce a http request which guest browsers don't really like to have embedded in the https request.

2. When executing job.php, I now always get a "An unkown error occured. Please try later."Is there a way to reset xf?