1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot Reproduce Creating a new child Style of a custom style result in weirdness?!?

Discussion in 'Resolved Bug Reports' started by Miko, Jan 18, 2011.

  1. Miko

    Miko Well-Known Member

    This one is odd one....

    I have created a new child style of a heavily customised style.

    The result is very strange...

    All of the templates are correct and identical to the parent style

    The style properties are from a different style that I used to have installed! That's right the style properties are from a style that was uninstalled several days ago :confused:

    Even the @imagePath is not from the parent style and definitely from the removed style...

    The Master style is 100% untouched.

    I'm very confused about all of this as it never happen before, hope Mike or Kier have an idea of what it could be causing it.

    Thank you.

    Edit: I have tested it on three installation of XF and it's only happening on my localhost, MAMP Pro on OS X 10.6.6 still very confused :p

    Edit 2: I have now created 3 child styles and finally I have a the correct one...
    believe it or not one of the mixed styles is quite nice!

    Edit 3: I have deleted all child styles and created a few new one to test and it's now working as designed.
  2. Peggy

    Peggy Well-Known Member

    Sounds like you're having a good day miko, lol. That is indeed an odd one.
  3. dieketzer

    dieketzer Well-Known Member

    i experienced a strange anomaly myself. i reverted a child style and the parent somehow inherited that data and insisted it was default.
  4. Kier

    Kier XenForo Developer Staff Member

    I don't suppose you have a backup of the DB from when you had a problem, or if you can get it back to a point where you could reproduce it do you? That would help to work out what was going on.
  5. Miko

    Miko Well-Known Member

    No, just in between Time Machine saves :(

    Any particular place where i could look to see if I have anything odd in case it happen again ?
  6. Kier

    Kier XenForo Developer Staff Member

    Re: our conversation last night, if you see this happen again, dump your DB before you continue so I can try to work out what's going on.

Share This Page