1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Correct way to enable XCache

Discussion in 'XenForo Questions and Support' started by polle, Aug 1, 2014.

  1. polle

    polle Active Member

    I have this in my config and it makes nothing, not caching at all.

    Code:
    $config['cache'] = array(
        'enabled' => true,
        'frontend' => 'Core',
        'frontendOptions' => array(
                'caching' => true,
                'automatic_serialization' => false,
                'cache_id_prefix' => 'xenf_',
                'lifetime' => 18000
        ),
        'backend' => 'Xcache',
        'backendOptions' => array(),
        'cacheSessions' => true
    );
    Is that completely wrong? I cant find a decent correct example or documentation for this.

    Thank you.
     
  2. Karelke

    Karelke Active Member

    Before we switched to APC, we had Xcache running with the following config:

    PHP:
    $config['cache']['enabled'] = true;
    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions']['cache_id_prefix'] = 'xf_';
    $config['cache']['backend'] = 'Xcache';
     
  3. MattW

    MattW Well-Known Member

    What is your Xcache config like? Have you allocated memory to both the opcache section (xcache.size), and the var section (xcache.var_size)?

    PHP:
    $config['cache']['enabled'] = true;
    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions']['cache_id_prefix'] = 'xf_';
    $config['cache']['cacheSessions'] = true;
    $config['cache']['backend']='Xcache';
    ^^ that is what I had set when using Xcache.
     
  4. polle

    polle Active Member

    Thank you both, but none of those worked for me.

    I installed this and now its working. Maybe it helps someone looking for the same.
     

Share This Page