1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Controller response error log

Discussion in 'Resolved Bug Reports' started by bogus, May 31, 2011.

  1. bogus

    bogus Guest

    I get an error in ACP Error log displayed but dont know what it means or what it is looking for

    Error-Log
    Code:
    array(3) {
      ["url"] => string(39) "http://www.brainlag.eu/find-new/116736/"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(0) {
      }
    }
    Thanks for your help
     
  2. Mike

    Mike XenForo Developer Staff Member

    That's not actually a valid URL, but that it indeed throw an error when you hit it, so that's a bug.
     
  3. bogus

    bogus Guest

    Hi Mike. Thanks, i thought so, but was not sure about it. Have you any idea what could be the cause?
     
  4. Mike

    Mike XenForo Developer Staff Member

    Someone likely manually manipulated the URL.
     
  5. bogus

    bogus Guest

    I have deativated every Addon, and was looking around the Templates included the find_new_threads Template but i cant find anything thats causing this..... The Error itself is still on :(
     
  6. Mike

    Mike XenForo Developer Staff Member

    You know, just looking into this again, and I'm not getting a server error - just the expected page couldn't be found error. I do see that the error is still happening on your site though.

    Can anyone else reproduce this? You just need to hit "what's new" and then take "threads" off the end (eg, http://xenforo.com/community/find-new/12345/). You should get a page couldn't be found error (or it saying the controller doesn't define an action, in debug mode).

    This looks like it might be caused by an add-on.
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    It seems to be TaigaChat based on some quick testing.

    error.PNG
     
  8. ragtek

    ragtek Guest

    hm yes, i think think it's from the chat too.

    The first 3 methods doesn't return anything, if the first if isn't true (but don't know why they shouldn't be true)
     
  9. Mike

    Mike XenForo Developer Staff Member

    This appears to be triggered by TaigaChat, though it leads us to a couple of questions about how to handle what the TaigaChat code is doing.
     
  10. Mike

    Mike XenForo Developer Staff Member

    It's actually because the code tries to extend actions that don't exist otherwise. Mostly this spawns off extending a bunch of controllers that way. I think something could be done with _postDispatch or one of the front controller hooks instead.
     
    bogus, Darkimmortal and ragtek like this.
  11. GencnesilleR

    GencnesilleR Member

    Code:
    XenForo_Exception: No controller response from XenForo_ControllerPublic_Thread::actionIndex - library/XenForo/FrontController.php:428
    Generated By: Bilinmeyen Hesap, Bugün 6:38 AM
    Stack Trace
     
    #0 /home/gencnes1/domains/gencnesiller.com/public_html/library/XenForo/FrontController.php(318): XenForo_FrontController->_handleControllerResponse(NULL, 'XenForo_Control...', 'Index')
    #1 /home/gencnes1/domains/gencnesiller.com/public_html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #2 /home/gencnes1/domains/gencnesiller.com/public_html/index.php(18): XenForo_FrontController->run()
    #3 {main}
     
    Request State
     
    array(3) {
      ["url"] => string(94) "http://www.gencnesiller.com/threads/yerdeki-y%C4%B1ld%C4%B1zlar-filminden-bir-par%C3%A7a.4260/"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(0) {
      }
    }
    
    Code:
    No controller response from XenForo_ControllerPublic_Thread::actionIndex Bugün 7:53 AM - library/XenForo/FrontController.php:428
    Sil...
    No controller response from XenForo_ControllerPublic_Thread::actionIndex Bugün 6:38 AM - library/XenForo/FrontController.php:428
    Sil...
    No controller response from XenForo_ControllerPublic_Thread::actionIndex Bugün 6:31 AM - library/XenForo/FrontController.php:428
    
    how yo fixed?
     
  12. GencnesilleR

    GencnesilleR Member

    the issue I am also referring to stop these errors I'm getting.
     

Share This Page