1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Connecting on Dreamweaver CS4 over WebDAV fails

Discussion in 'XenForo Questions and Support' started by Tigratrus, Feb 16, 2011.

  1. Tigratrus

    Tigratrus Well-Known Member

    I'm trying to configure the webdav connection and it just keeps failing, so I'm wondering if I'm simply doing something fundamentally wrong.

    I have no problem setting up an FTP connection that works perfectly.

    Should we be using the domain account and password (as we would for FTP) when connecting to WebDAV? Or should we be using an XF admin account? Or a MySQL account?

    I've got XF installed at the root, and I'm trying to connect at the url:

    I've tried with all the different accounts I can think of and I keep getting:

    "An HTTP error occurred. Dreamweaver cannot make a connection to the host. Your login or password is incorrect. Please check your connection information."

    Can someone that's got WebDAV setup and working right provide some insight?

  2. James

    James Well-Known Member

    You use the XF admin account AFAIK. You also must be in debug mode (at least for your IP) for the connection to work - also IIRC.
  3. Tigratrus

    Tigratrus Well-Known Member

    Site's been in debug mode for quite awhile, I've tried using an XF admin account but without any luck. I can work on troubleshooting it on the server config end, I just need to be sure I'm trying to connect with the right account/password so I'm not chasing a ghost.

    Is there anyone that's currently got it currently setup that can confirm?
  4. Tigratrus

    Tigratrus Well-Known Member

    This is really driving me nuts. If I hit the WebDAV url (http://www.domain.com/admindav.php) directly, I get a user and password prompt:

    The server www.domain.com:80 at XenForo Admin CP WebDAV requires a username and password.

    User Name:

    But nothing works, it refuses all account/password combinations. I've tried my james_sa (full admin account created during XF install) account, the domain (CentOS User/website/ftp/cpanel) account, the root account for both the server and for the MySQL, the MySQL account that XF is running under... EVERYTHING!

    Can someone please help me eliminate the variables by specifying exactly *should* be working, and hopefully give me some idea how to troubleshoot this? It doesn't look like it's being blocked, it looks like it's simply not authenticating...

    Help? Pretty please?
  5. Kier

    Kier XenForo Developer Staff Member

    You don't have your site behind .htaccess do you?
  6. Tigratrus

    Tigratrus Well-Known Member

    I believe we're using the XF full friendly URLS? So there's a .htaccess consisting of:

    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    <IfModule mod_rewrite.c>
        RewriteEngine On
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data|js|styles|install) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
  7. Kier

    Kier XenForo Developer Staff Member

    Sorry, I asked the wrong question. What I meant to ask is whether or not your site is password protected in any way?

    Reason being that WebDav employs HTTP Basic Auth, which is the same used by normal password protection, so an accessible XenForo WebDav system cannot be located behind a .htaccess-style protection layer.
  8. Tigratrus

    Tigratrus Well-Known Member

    I just spend the early evening getting Zend CE Server setup, configured and XF installed locally on my OSX. Once that was up and running I was able to put it in debug and connect with my XF admin account in Dreamweaver. So I've been doing it right all along. Is the .htaccess keeping it from authenticating somehow?
  9. Tigratrus

    Tigratrus Well-Known Member

    No... The root isn't password protected. The only odd thing is that it's configured as an exact duplicate of our live server, so I have to use a hosts file on my machine to pre-empt the DNS lookup and map the domain to the IP of the testbed vs. the live server. Can't imagine why that would be causing a problem though... Everything else works perfectly both in and out of the ACP.
  10. Kier

    Kier XenForo Developer Staff Member

    If that's all that's in your .htaccess, and there's nothing specified in your VirtualHost setup or higher in the Apache config then no, that's not what's stopping it.

    I'll show you my WebDav settings:
    Screen shot 2011-02-17 at 03.54.46.png Screen shot 2011-02-17 at 03.54.57.png Screen shot 2011-02-17 at 03.55.00.png Screen shot 2011-02-17 at 03.56.01.png
    Rob Fritz and Tigratrus like this.
  11. Kier

    Kier XenForo Developer Staff Member

    Just as a debugging thing, try making both your username and password both consist of a-z, 0-9 characters only (no spaces) and see if that makes any difference.
  12. Tigratrus

    Tigratrus Well-Known Member

    Thanks. I suppose it might well be something in the security setup of the server. Now that I know for certain *exactly* what account/password should be working I can troubleshoot it with the Liquid Web techs on that end. ::sigh::

    Well, this is why we HAVE a testbed, to ID all the potential problems *before* we try to do anything on the live server!
    Thanks Kier... I'll post back on this thread when I find out what's blocking it, maybe it'll help someone in the future. ;)
    Kier likes this.
  13. Shadab

    Shadab Well-Known Member

    Jake Bunce and Tigratrus like this.
  14. Tigratrus

    Tigratrus Well-Known Member

    It does indeed! Thanks Shadab, you're my hero. :)

    For anyone with the same issue trying to connect to WebDAV and being unable to authenticate making Shadab's change to the .htaccess (adding the ^admindav.php line below) DID fix it for us.

    RewriteEngine On
    RewriteRule ^admindav.php - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},NC,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data|js|styles|install) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    Jake Bunce, Kier and Shadab like this.
  15. Kier

    Kier XenForo Developer Staff Member

    I'm glad you managed to get that fixed, though I'm a little perplexed as to why I haven't had to include that extra line in my own Zend Server CE config, or for the admindav.php file right here on XenForo.com. Oh well, at least it's working for you now. :)

Share This Page