1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Confirmation email

Discussion in 'Troubleshooting and Problems' started by clockwork71, Dec 31, 2012.

  1. clockwork71

    clockwork71 Member

    Guys,

    I have recently moved my forum from domainname.com/forums to domainname.com/forum as I am using the Jaxel written Portal. I have moved everything to set like this:

    Portal is the root page now.

    Forums are in /forum (the default of the portal.)

    Now I am getting emails from people telling me that they cannot register because the conformation email is still trying to have them click a link to the old subfolder that the forum is in. (forums) Is there a way to change that? I am sure there is....but can't find it.

    Chris
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    Hi Chris,

    The setting you need to change is:

    Admin CP > Options > Basic Board Information > Board URL
     
    Jake Bunce and Morgain like this.
  3. Morgain

    Morgain Well-Known Member

    First very basic check - admin/ options/ options/
    Basic Board Information
    Board URL ....................... ?
    I assume you have that changed correctly as otherwise I dont think your XF would run at all but worth a quick look.

    Similarly Home Page URL - same page.
    maybe other settings three.

    Always worth checking the obvious first.
     
    Jake Bunce likes this.
  4. Chris D

    Chris D XenForo Developer Staff Member

    It definitely will be the board URL. The board would work mostly fine with the wrong board URL. But it is used to form links so if it hasn't been updated its definitely that which is the problem.

    Home page URL isn't involved because I believe that's just the URL the home tab points to.

    But yeah. Spot on asking him to check board URL (y)
     
    Jake Bunce and Morgain like this.
  5. clockwork71

    clockwork71 Member

    I've done both, and it still redirects to a page that "isn't found."
     
  6. Chris D

    Chris D XenForo Developer Staff Member

    Then it still isn't right.

    What is the URL you have set as your Board URL? What does that URL take you to?
     
    Jake Bunce likes this.
  7. clockwork71

    clockwork71 Member

    I have it set to thetraderguy.com/forum - and it takes me to the forums. However, when emails get send out in order for people to verify registration - it says the page doesn't exist. I am confused to say the least.

    The homepage is thetraderguy.com, and sends someone to the portal.
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    You need to set the board URL to the root URL of your XenForo installation, or, to put it another way, your XenForo index page. In this case, your XenForo index has been changed to XenPorta. XenPorta is accessible from http://thetraderguy.com

    You therefore need to set your board URL to http://thetraderguy.com
     
    Jake Bunce likes this.
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Chris is correct. /forum is a route in your case, not a directory. That should not be included in the Board URL.
     
    Chris D likes this.
  10. clockwork71

    clockwork71 Member

    Thanks guys......got it working now.
     

Share This Page