Configuring Amazon SES

#1
Have got SES account set up, have been released from the sandbox.

I cannot get the emails to send. I continue to receive Connection Errors in my error log. I think I've got all setting correct in the Email Options page, but something is not right and I need help.
 

fly

Active member
#5
Have got SES account set up, have been released from the sandbox.

I cannot get the emails to send. I continue to receive Connection Errors in my error log. I think I've got all setting correct in the Email Options page, but something is not right and I need help.
What is the error?
 
#14
Same problem here, 587 seems to be opened.
the forum is under /forum folder, can be this the problem?


server error log:
  • Code:
    Swift_TransportException: Email to *****@gmail.com failed: Connection could not be established with host email-smtp.eu-west-1.amazonaws.com [Connection refused #111] src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php:277
 
Last edited:

Jake B.

Well-known member
#15
Same problem here, 587 seems to be opened.
the forum is under /forum folder, can be this the problem?


server error log:
  • Code:
    Swift_TransportException: Email to *****@gmail.com failed: Connection could not be established with host email-smtp.eu-west-1.amazonaws.com [Connection refused #111] src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php:277
You'd likely need to contact your host about something like this, something is blocking you from connecting to SES
 
#16
You'd likely need to contact your host about something like this, something is blocking you from connecting to SES
Ok now I can contact amazon SMTP, but I have an other error:
Code:
Swift_TransportException: Email to ****@gmail.com failed: Expected response code 250 but got code "554", with message "554 Message rejected: Email address is not verified. The following identities failed the check in region US-EAST-1: <****@gmail.com>, ****@gmail.com, xenforousername <admin@xenforosite.com> "
I also have verified Email Address Identities. I think it appends because it is in sandbox mode
 
#18
My mistake, I had selected the wrong datacenter as a host. Now it works, I have the limit to 250 monthly mails, I opened a tiket to increase it.
I have another question. I read that I have to clean up the list to which I send the newsletter, to avoid a high percentage of rebounds. How can I do it on xenforo?
 
Top