• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug Changing the js url is not reflected in ACP

#1
Recently I changed the JS URL and move the folder.

After that, our ACP started to act broken, and upon inspection it became apperant that the js urls for the admin panel are not updated with the url supplied in config.php

(Please note that our site works fine with the updated js urls, just not the acp)

Code:
https://removed.tld/js/jquery/jquery-1.11.0.min.js Failed to load resource: the server responded with a status of 404 (Not Found)
https://removed.tld/js/xenforo/xenforo.js?_v=5c7fab60 Failed to load resource: the server responded with a status of 404 (Not Found)
https://removed.tld/js/xenforo/acp_quicksearch.js?_v=5c7fab60 Failed to load resource: the server responded with a status of 404 (Not Found)
https://removed.tld/js/xenforo/acp_nav.js?_v=5c7fab60 Failed to load resource: the server responded with a status of 404 (Not Found)
https://removed.tld/js/liquidpro/simpleforms/jquery-ui.custom.js?_v=5c7fab60 Failed to load resource: the server responded with a status of 404 (Not Found)
https://removed.tld/js/liquidpro/simpleforms/simpleforms.js?_v=5c7fab60 Failed to load resource: the server responded with a status of 404 (Not Found)
https://removed.tld/js/liquidpro/simpleforms/jquery.timepicker.js?_v=5c7fab60 Failed to load resource: the server responded with a status of 404 (Not Found)
https://removed.tld/js/xenforo/sidebar.js?_v=5c7fab60 Failed to load resource: the server responded with a status of 404 (Not Found)
Where in the js url, it's https://static.removed.tld
 

Mike

XenForo developer
Staff member
#2
This is intentional and expected. The JS URL option controls the public facing area only. You should duplicate to your JS URL rather than moving.