1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Change default user timeout

Discussion in 'XenForo Questions and Support' started by ViciousGnome, Jul 10, 2013.

  1. ViciousGnome

    ViciousGnome Active Member

    Hello, and thank you for trying to assist me.

    I have been doing updates via the Admin CP, and when I change browsers to check something and comeback and try to make a change, I get the "you are not logged in" error. Am I timing out? Can I change the default user timeout, and if so, how?

    Thanks again.
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    In a dev environment you can enable debug mode by adding this to the library/config.php file:

    $config['debug'] = 1;
    That will cause admin sessions to last for 24 hours. Otherwise it's a 1 hour timeout.
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Use Chrome and set up different profiles.
    That way you can be logged in (or out) with multiple accounts.
  4. ViciousGnome

    ViciousGnome Active Member

    I'm a little confused. What is happening is about 1 in 4 saves I am trying to make in the Admin CP is being denied, with the following error:

    The following error occurred:
    This action could not be completed because you are no longer logged in.

    It's happening now, without me changing browsers. I am using Firefox 22.0. I am at work, behind a firewall that blocks sites, but my site isn't blocked. Any ideas what the issue might be?
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Sounds like a cookie issue.

    Try it at home - if it works then it is your company firewall/browser.
  6. ViciousGnome

    ViciousGnome Active Member

    I'll try it at home. I'll also check the cookie settings on the browser I'm on now. Thanks Brogan.
  7. Amaury

    Amaury Well-Known Member

    For future reference, if you ever do want to change it for users: Admin CP -> Options -> User Options -> Online Status Timeout

    It's set to 15 minutes by default.
  8. ViciousGnome

    ViciousGnome Active Member

    Thank you very much, this was EXACTLY what I was looking to do. Now if I can only figure out how to change the default font for the forums... lol
  9. Brogan

    Brogan XenForo Moderator Staff Member

Share This Page