1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Beta CFDDoS 1.0.2

Automatically Enable CloudFlare DDoS Protection

  1. Lyphiard

    Lyphiard Active Member

    Lyphiard submitted a new resource:

    CFDDoS - Automatically Enable CloudFlare DDoS Protection

    Read more about this resource...
     
    RoldanLT likes this.
  2. RoldanLT

    RoldanLT Well-Known Member

    Looks great and promising addon. (y)
     
  3. Lyphiard

    Lyphiard Active Member

    Thanks :)

    Looking to add other things as visitors per second as well as network traffic later on!
     
    RoldanLT likes this.
  4. TH-Designs

    TH-Designs New Member

    my site went down just after installing it, had to remove it for now...
     
  5. Lyphiard

    Lyphiard Active Member

    Could you provide more details? Were there any errors?
     
  6. Lyphiard

    Lyphiard Active Member

  7. BobbyWibowo

    BobbyWibowo Well-Known Member

    @Lyphiard I got these errors during rebuild processes:
    x-auth-errors.png
    And that happened with v1.0.1.

    UPDATE: Once I got the server error during the rebuild processes, I had to went to the add-on's options and add the necessary information. After that I had to continue the rebuild processes, and it'd rebuild just fine after that. I'll now proceed to ask one my contacts to wreck my site for "experiments", lol..
     
    Last edited: Mar 28, 2016
    RoldanLT likes this.
  8. Lyphiard

    Lyphiard Active Member

    Could you open up one of the errors and post the full stack trace?
     
  9. BobbyWibowo

    BobbyWibowo Well-Known Member

    @Lyphiard Crap, I deleted the logs xD Give me a moment to reinstall, lmao. But FYI, I updated my post with some extra information (not the stack trace though).
     
  10. Lyphiard

    Lyphiard Active Member

    That error appears only when the addon tries to make a CloudFlare request without you entering the api keys. I thought I fixed it, but I might have missed a place (Trying to code on a phone through Remote Desktop :p)
     
  11. BobbyWibowo

    BobbyWibowo Well-Known Member

    Sounds like a pain in the ass, lol

    Anyway, I tried to reinstall the add-on again. But for some reasons, I couldn't get the errors to pop out this time around. Although, before I realized how to get around it, I tried to reinstall the add-on twice and got the errors on both tries.

    EDIT: Site broke down after a few moments. And the "I'm Under Attack" mode was enabled by itself, for some reasons.
     
  12. BobbyWibowo

    BobbyWibowo Well-Known Member

    Error Info:
    Stack Trace:
    Code:
    #0 /home/nginx/domains/endlesshorizon.net/public/library/CFDDoS/Model/CloudFlare.php(95): CFDDoS_Model_CloudFlare->_checkForErrors('{"success":fals...')
    #1 /home/nginx/domains/endlesshorizon.net/public/library/CFDDoS/Model/CloudFlare.php(42): CFDDoS_Model_CloudFlare->_getZoneId()
    #2 /home/nginx/domains/endlesshorizon.net/public/library/CFDDoS/Listener.php(32): CFDDoS_Model_CloudFlare->disableProtection()
    #3 [internal function]: CFDDoS_Listener::init_dependencies(Object(XenForo_Dependencies_Public), Array)
    #4 /home/nginx/domains/endlesshorizon.net/public/library/XenForo/CodeEvent.php(90): call_user_func_array(Array, Array)
    #5 /home/nginx/domains/endlesshorizon.net/public/library/XenForo/Dependencies/Abstract.php(215): XenForo_CodeEvent::fire('init_dependenci...', Array)
    #6 /home/nginx/domains/endlesshorizon.net/public/library/XenForo/FrontController.php(127): XenForo_Dependencies_Abstract->preLoadData()
    #7 /home/nginx/domains/endlesshorizon.net/public/index.php(13): XenForo_FrontController->run()
    #8 {main}
     
  13. Lyphiard

    Lyphiard Active Member

  14. BobbyWibowo

    BobbyWibowo Well-Known Member

    Updated the add-on on my board. Can't confirm whether it works or not, at the moment. But there have been no errors.
    By the way, thanks a lot for the add-on!
     

Share This Page