• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

CFDDoS 1.0.2

No permission to download

Lyphiard

Active member
#1
Lyphiard submitted a new resource:

CFDDoS - Automatically Enable CloudFlare DDoS Protection

This is a simple addon that will automatically enable cloudflare's "I'm under attack" mode once your server reaches a pre-defined load average.

After waiting a pre-defined time period, the addon will check to see if the server is still above said average. If so, it will wait another X seconds. If the load average has dropped, then the addon will disable "I'm under attack" mode.

To configure, navigate to Home -> Options -> CFDDoS Options. Then, add in your cloudflare email, api key, and the...
Read more about this resource...
 

BobbyWibowo

Well-known member
#7
@Lyphiard I got these errors during rebuild processes:
x-auth-errors.png
And that happened with v1.0.1.

UPDATE: Once I got the server error during the rebuild processes, I had to went to the add-on's options and add the necessary information. After that I had to continue the rebuild processes, and it'd rebuild just fine after that. I'll now proceed to ask one my contacts to wreck my site for "experiments", lol..
 
Last edited:

Lyphiard

Active member
#10
@Lyphiard Crap, I deleted the logs xD Give me a moment to reinstall, lmao. But FYI, I updated my post with some extra information (not the stack trace though).
That error appears only when the addon tries to make a CloudFlare request without you entering the api keys. I thought I fixed it, but I might have missed a place (Trying to code on a phone through Remote Desktop :p)
 

BobbyWibowo

Well-known member
#11
I thought I fixed it, but I might have missed a place (Trying to code on a phone through Remote Desktop :p)
Sounds like a pain in the ass, lol

Anyway, I tried to reinstall the add-on again. But for some reasons, I couldn't get the errors to pop out this time around. Although, before I realized how to get around it, I tried to reinstall the add-on twice and got the errors on both tries.

EDIT: Site broke down after a few moments. And the "I'm Under Attack" mode was enabled by itself, for some reasons.
 

BobbyWibowo

Well-known member
#12
Error Info:
XenForo_Exception: CloudFlare Error(s): (9106) Missing X-Auth-Email header, (9107) Missing X-Auth-Key header - library/CFDDoS/Model/CloudFlare.php:121
Generated By: Unknown Account, 6 minutes ago
Stack Trace:
Code:
#0 /home/nginx/domains/endlesshorizon.net/public/library/CFDDoS/Model/CloudFlare.php(95): CFDDoS_Model_CloudFlare->_checkForErrors('{"success":fals...')
#1 /home/nginx/domains/endlesshorizon.net/public/library/CFDDoS/Model/CloudFlare.php(42): CFDDoS_Model_CloudFlare->_getZoneId()
#2 /home/nginx/domains/endlesshorizon.net/public/library/CFDDoS/Listener.php(32): CFDDoS_Model_CloudFlare->disableProtection()
#3 [internal function]: CFDDoS_Listener::init_dependencies(Object(XenForo_Dependencies_Public), Array)
#4 /home/nginx/domains/endlesshorizon.net/public/library/XenForo/CodeEvent.php(90): call_user_func_array(Array, Array)
#5 /home/nginx/domains/endlesshorizon.net/public/library/XenForo/Dependencies/Abstract.php(215): XenForo_CodeEvent::fire('init_dependenci...', Array)
#6 /home/nginx/domains/endlesshorizon.net/public/library/XenForo/FrontController.php(127): XenForo_Dependencies_Abstract->preLoadData()
#7 /home/nginx/domains/endlesshorizon.net/public/index.php(13): XenForo_FrontController->run()
#8 {main}
 

BobbyWibowo

Well-known member
#14
Updated the add-on on my board. Can't confirm whether it works or not, at the moment. But there have been no errors.
By the way, thanks a lot for the add-on!
 
#15
An exception occurred: CloudFlare Error(s): (6003) Invalid request headers in /home/gszone/public_html/library/CFDDoS/Model/CloudFlare.php on line 121

  1. CFDDoS_Model_CloudFlare->_checkForErrors() in CFDDoS/Model/CloudFlare.php at line 95
  2. CFDDoS_Model_CloudFlare->_getZoneId() in CFDDoS/Model/CloudFlare.php at line 7
  3. CFDDoS_Model_CloudFlare->enableProtection() in CFDDoS/Listener.php at line 21
  4. CFDDoS_Listener::init_dependencies()
  5. call_user_func_array() in XenForo/CodeEvent.php at line 90
  6. XenForo_CodeEvent::fire() in XenForo/Dependencies/Abstract.php at line 215
  7. XenForo_Dependencies_Abstract->preLoadData() in XenForo/FrontController.php at line 127
  8. XenForo_FrontController->run() in /home/gszone/public_html/admin.php at line 13