1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Can't upload attachments

Discussion in 'Resolved Bug Reports' started by CyberAP, Mar 7, 2016.

  1. CyberAP

    CyberAP Well-Known Member

  2. Brogan

    Brogan XenForo Moderator Staff Member

    Do you mean on a resource or post here?
    On your own site?

    I just managed to upload the .zip to both a post and resource here without issue.
     
  3. CyberAP

    CyberAP Well-Known Member

    Everywhere on this site.
    Yesterday I had the same problem but it didn't gave me an error, just took a long time to upload. This time I can't upload anything. It just gets to 100% and after some time brings an error message: "There was a problem uploading your file." I also noticed it happens for all attachments, not just this one.

    Tested this on localhost. It works fine there.

    Checked console:

    Failed to load resource: net::ERR_CONNECTION_RESET
    attachment_editor.js?_v=5c8fb20e:12 Upload failed: Arguments[3]


    Also, Error #2038.
     
    Last edited: Mar 7, 2016
  4. CyberAP

    CyberAP Well-Known Member

    Now I have connection reset even on post save! I suppose this is host-related?
     
  5. CyberAP

    CyberAP Well-Known Member

    Last edited: Mar 7, 2016
  6. Chris D

    Chris D XenForo Developer Staff Member

    Can you disable the flash uploader in your preferences and try again? Sometimes swfupload masks a decent error message.
     
  7. CyberAP

    CyberAP Well-Known Member

    Seems this issue is nor browser or flash-related. Tested attachments in Firefox, Edge — same problem. Tested pasting big amounts of data — same problem. HTML uploader — same problem.
     
  8. Mike

    Mike XenForo Developer Staff Member

    This really seems like a connection issue on your side or at least between you and the server (not XenForo the software as it won't have been invoked yet). For example, there could be packet loss on the route to the server.
     
  9. CyberAP

    CyberAP Well-Known Member

    How can I check that?
    I did trace route and here are the results: http://pastebin.com/UfyRrqB1
    Ping didn't show any packet loss even after 35 tries.
    This issue occurs only on XenForo.com and only with big amounts of data.
     
  10. CyberAP

    CyberAP Well-Known Member

    With all respect, your assumption is wrong.
    I just tested it again and again. Files start to upload, but then eventually at some point server responds with error 2038.
    To prove that here is the console log again:

    Code:
    Queued: velour.zip (33755 bytes)
    attachment_editor.js?_v=5c8fb20e:11 Uploading velour.zip
    file_uploader.js?_v=5c8fb20e:8 Uploaded 0/33755 bytes.
    file_uploader.js?_v=5c8fb20e:8 Uploaded 34910/33755 bytes.
    https://xenforo.com/community/attachments/do-upload.json?hash=539f1df09962bc8f448a47de5a8e297d&content_type=resource_version&key=resource Failed to load resource: net::ERR_CONNECTION_RESET
    jquery.min.js:4 POST https://xenforo.com/community/resources/velour.5080/save-draft net::ERR_CONNECTION_RESETsend @ jquery.min.js:4n.extend.ajax @ jquery.min.js:4c.extend.ajax @ xenforo.js?_v=5c8fb20e:228XenForo.BbCodeWysiwygEditor.saveDraft @ bb_code_edit.js?_v=5c8fb20e:38(anonymous function) @ bb_code_edit.js?_v=5c8fb20e:37
    attachment_editor.js?_v=5c8fb20e:12 Upload failed: [Object, -220, "Error #2038"]
    attachment_editor.js?_v=5c8fb20e:12 All files uploaded.
    BTW, to post this I had to wait about 30-40 seconds. But usually it takes 1 or 2.
     
  11. CyberAP

    CyberAP Well-Known Member

    Update: issue has gone with a combination of FireFox + HTML Uploader.
    Update 2: works with Flash uploader in Edge.
    Update 3: somehow issue has gone even in Chrome. I guess something has changed.
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    Have you tried disabling the Flash uploader as Chris suggested?

    I have seen reference to that causing #2038 errors.
     
  13. CyberAP

    CyberAP Well-Known Member

    I did yesterday, that didn't help. Today it's working both with Flash and HTML and I don't know why. But literally 5 minutes before I couldn't upload anything.
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    We haven't made any changes so the only thing it can be is something specific to you - network, device, connection, etc.

    No-one else seems to be having issues uploading files using various browsers, devices and OS, with the Flash uploader enabled.
     
  15. CyberAP

    CyberAP Well-Known Member

    I know, XenForo.com is the only site that I'm having trouble with uploading files. Next time it happens I will try to disable Chrome extensions 1 by 1 to see if that affects anything.
     
  16. CyberAP

    CyberAP Well-Known Member

    It's happening again right now. I am using Chrome Incognito mode with all extensions disabled. Plus only HTML uploader. And it's failing, again. Here is what console got to say:

    Code:
    Failed to load resource: net::ERR_CONNECTION_RESET
    jquery.min.js:2 Uncaught SecurityError: Failed to read the 'contentDocument' property from 'HTMLIFrameElement': Blocked a frame with origin "https://xenforo.com" from accessing a frame with origin "null".  The frame requesting access has a protocol of "https", the frame being accessed has a protocol of "data". Protocols must match.
    Edit: can't make long posts either.
     
  17. CyberAP

    CyberAP Well-Known Member

    Then I enabled Flash uploader, console log: http://pastebin.com/DKLVTyDy

    Notice how it uploads more data than required, is this by design?
    What should I do to fix this if it's a problem on my side?
     
  18. Moshe1010

    Moshe1010 Well-Known Member

    Have you tried to upload the file connecting to a different network?
     
  19. CyberAP

    CyberAP Well-Known Member

    No, I don't have another network.
     
  20. XenBurger

    XenBurger Member

    Testing. Having the same problem on our forums.
     

    Attached Files:

Share This Page