1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't upgrade to RC3 (from RC2)

Discussion in 'Installation, Upgrade, and Import Support' started by dmnkhhn, Feb 23, 2011.

  1. dmnkhhn

    dmnkhhn Active Member

    Hey guys,

    I can't upgrade from RC2 to RC3… XenForo RC2 is installed on my local server.

    I created a new folder, moved all files from the upgrade package to that folder and copied 'data', 'internal_data' and 'config.php' from the RC2 folder to the new location.

    When I open the installation (new folder) I get the message that the forums are currently updated. When I open the installer I get 'Your server meets all of XenForo requirements and you're now ready to begin installation.'

    It worked when I upgraded from RC1 to RC2 - what am I doing wrong here?

    Edit:
    The first error message I get is 'You have already completed installation. If you wish to reinstall, please delete the file internal_data/install-lock.php.' - Removing that files gives me the message from above.

    Edit 2:
    Strange, I got it working by typing in the path to the upgrade process by hand.

    Problem solved, thanks. ;)
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    For reference, why are you doing it this way?

    All you need to do is upload the new files overwriting the old ones.
     
  3. dmnkhhn

    dmnkhhn Active Member

    The Mac Finder replaces folders including all files instead of merging them. :)
    I wasn't sure if the upgrade package contains all files and I didn't want to risk losing a file when overwriting the folders.

    On my server, I am using either Transmit (syncing) or rsync but this is only my local development server.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    So there's no way of merging folders on a Mac?
    That seems like a fairly big limitation.

    The upgrade package doesn't contain the following:
    • .htaccess
    • config.php
    • /data
    • /internal_data
     
    Walter likes this.
  5. dmnkhhn

    dmnkhhn Active Member

    Now I know, thanks. :)

    I don't know if there is a simple trick to do it but from what I have learnt, the Finder always replaces the whole folder.
     
  6. RobParker

    RobParker Well-Known Member

    Not with Finder. You can of course use the terminal with cp/mv.

    Yep it's stupid. I lost a local install of XF when I upgraded before I realised.
     

Share This Page