1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Can't save forums...

Discussion in 'Troubleshooting and Problems' started by faeronsayn, Jun 25, 2013.

  1. faeronsayn

    faeronsayn Well-Known Member

    I keep getting this error when trying to save forums.

    Mysqli prepare error: Unknown column 'allowed_watch_notifications' in 'field list'

    After the update to xenForo v1.2 all my thread orders are messed up in each and every one of my forums. Any quick fix for this? When I try to get into the forum to set it's default thread order, I get an error that no valid value is selected so I select one of the watch forum options to receive the error above.
  2. Mike

    Mike XenForo Developer Staff Member

    It sounds like your upgrade to 1.2 actually failed due to add-on conflicts. I could only recommend restoring your 1.1.5 backup, removing any conflicting add-ons (ensuring their data is removed from the database) and then retrying the upgrade.
  3. faeronsayn

    faeronsayn Well-Known Member

    I did come from v1.1.4, could that be an issue? Furthermore, is there anyway to salvage the current install? If there were any major failures when upgrading to v1.2.0 I would assume that the updater would identify them?

    Here is an error from the error log regarding the default sorting order..

    ErrorException: Undefined index: default_sort_order - library/XenForo/ControllerPublic/Forum.php:291

    #0 /home2/asdf/public_html/library/XenForo/ControllerPublic/Forum.php(291): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home2/asdf/pu...', 291, Array)
    #1 /home2/asdf/public_html/library/XenForo/ControllerPublic/Forum.php(102): XenForo_ControllerPublic_Forum->_getDefaultThreadSort(Array)
    #2 /home2/asdf/public_html/library/XenForo/FrontController.php(335): XenForo_ControllerPublic_Forum->actionForum()
    #3 /home2/asdf/public_html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #4 /home2/asdf/public_html/index.php(13): XenForo_FrontController->run()
    #5 {main}
  4. faeronsayn

    faeronsayn Well-Known Member

    Would removing addons now and rebuilding master data do the job?
  5. xf_phantom

    xf_phantom Well-Known Member

    Try to run this query
    ALTER TABLE xf_forum
                    ADD require_prefix TINYINT UNSIGNED NOT NULL DEFAULT '0',
                    ADD allowed_watch_notifications VARCHAR(10) NOT NULL DEFAULT 'all',
                    ADD default_sort_order VARCHAR(25) NOT NULL DEFAULT 'last_post_date',
                    ADD default_sort_direction VARCHAR(5) NOT NULL DEFAULT 'desc'
  6. faeronsayn

    faeronsayn Well-Known Member

    That seems to have fixed it.
  7. ineedhelp

    ineedhelp Well-Known Member

    Database is asking me to choose at least one column before i can run the above query.

    Which column should I select?

    Do I have to select any tables as well as columns or just columns?

    Last edited: Jun 26, 2013
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You shouldn't have to select any columns. Just run the query. In phpmyadmin there is a SQL tab to run queries.
  9. ineedhelp

    ineedhelp Well-Known Member

    Fixed it - Thanks.

    All threads are displaying from 2011 first and todays last….. Do I need to rebuild cache?
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Yes, probably:

    Admin CP -> Tools -> Rebuild Caches

    I would guess that rebuilding the forum cache on this page is necessary after running that query.
  11. ineedhelp

    ineedhelp Well-Known Member

    Problem solved... I removed the require prefix line and the query worked fine! Fixed everything. So far from what I can tell!
  12. TBolley

    TBolley Active Member

    get same Error

    but on run

    get this error

    #1060 - Duplicate column name 'require_prefix'
  13. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That column must have been previously created by an addon in 1.1.x. You need to deal with this before upgrading (probably by uninstalling the addon).
  14. TsinJu

    TsinJu Well-Known Member

    Had something similiar with RC2
    If i just knew what addon this caused Oo
  15. Brogan

    Brogan XenForo Moderator Staff Member

    Judging by the column names it is something to do with watching forums and sorting the threads within them.

Share This Page