1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue Can't paste from clipboard into template [b6]

Discussion in 'Resolved Bug Reports' started by Floris, Jan 16, 2011.

  1. Floris

    Floris Guest

    I am on Mac OSX 10.6.6 with Safari/Chrome and in both I can't paste from clipboard into a template from beta 6.

    Alpha 3 / Beta 5 existing upgraded boards or fresh installs: Paste works fine.
    In beta 6 it just pretends to paste and doesn't actually show any data.

    Very strange.

    Anybody else experienced this?

    Close all browsers, go to plain text, copy "hello" into clipboard, go to beta 5 > admin.php > appearance > templates > member_view edit > paste > shows hello

    Repeat, now on beta 6, and it wont paste.
    Dean, Dan and Kaiser like this.
  2. Phil Vessey

    Phil Vessey Member

    Same happens on windows also. Im using latest version on Chrome on Windows 7. Tried to edit the same template as above with some content on the clipboard and it doesnt paste.
  3. Vincent

    Vincent Well-Known Member

    I got this too on windows 7, google chrome 8
  4. Andy.N

    Andy.N Well-Known Member

    Yeap, tried to edit some templates yesterday and it did not paste.
    beta 6, Chrome 8, XP
  5. Floris

    Floris Guest

    Thank you guys for testing for me, glad to find out it's not my computer setup or something strange like a browser plugin.
    Vincent likes this.
  6. Kaiser

    Kaiser Well-Known Member

    This is very annoying I have this issue also, so what I had to do was copy the whole template's code into notepad++ then edit it from there then copy and paste the whole entire code back into the template and then it worked, I had to delete all the codes first from the template.
  7. Mike

    Mike XenForo Developer Staff Member

    This has happened for some time with Chrome - it's not new to beta 6 in my experience. It appears to be a browser bug, but I'm not positive what causes it. You should still be able to paste into an empty field (I know this applies to <input type="text" />, don't know about textareas off hand).
  8. Mikey

    Mikey Well-Known Member

    I've only ever had this problem with xenforo text areas in chrome though. Never any other text areas (such as gmail reply form. (edit, gmail use <body contenteditable=""></body>)
  9. cmeinck

    cmeinck Well-Known Member

    Same problem here. Safari, Chrome on Mac -- Chrome in Windows.

    I hope this gets fixed. Makes it tough to make edits.

    Note: Copy and paste works in .css files, but not templates.
  10. TerminalAddict

    TerminalAddict Active Member

    mmm webkit acts differently? (safari, chrome)

    pasting works in firefox, not in chrome
  11. Floris

    Floris Guest

    Then it must be web kit, but I never had this in the past, and I copy/paste from every alpha to latest beta, and it's only happening on beta6 for me. I have every instance running on my area51. That said, I found out about it on Safari, Chrome was used to confirm it.

    Anyway. feedback
  12. Mike

    Mike XenForo Developer Staff Member

    Vincent likes this.
  13. Mikey

    Mikey Well-Known Member

    So roll on chrome 10 heh.
  14. Vincent

    Vincent Well-Known Member

    Ah, that sucks :( I like 8 :D
  15. dutchbb

    dutchbb Well-Known Member

    It's still an issue in the latest Safari though :/
  16. melbo

    melbo Well-Known Member

    I fixed it on Chrome by double clicking on the code I wanted to copy. That copied the 'blank space' around the code as well. Copy and the Paste and it worked. Not sure why. I
  17. Kier

    Kier XenForo Developer Staff Member

    Just checked this on the latest WebKit nightly build and it's been fixed. Now we just have to wait for Safari and Chrome to roll out updated versions of their browsers that include the fix.
  18. Dav

    Dav Active Member

    Im having this problem also and im using safari
  19. James

    James Well-Known Member

    Having this problem in Chrome 9.
  20. Kier

    Kier XenForo Developer Staff Member

    Vincent likes this.

Share This Page