Fixed Can't make a clean install

Affected version
2.0.2

cimad

Member
I have downloaded the 'update' and the 'full version', but I can't perform a clean installation, however, I can perform an update of the existing one.


If I don't use any config.php file appears the first error, but if i upload the config.php file, appears the second error.

it is possible that it is a temporary error of the host, but im not sure.


Code:
An exception occurred: [XF\Db\Exception] Access denied for user 'myhost'@'localhost' (using password: NO) in src/XF/Db/Mysqli/Adapter.php on line 160

XF\Db\Mysqli\Adapter->makeConnection() in src/XF/Db/Mysqli/Adapter.php at line 28
XF\Db\Mysqli\Adapter->getConnection() in src/XF/Db/AbstractAdapter.php at line 51
XF\Db\AbstractAdapter->connect() in src/XF/Db/Mysqli/Adapter.php at line 113
XF\Db\Mysqli\Adapter->escapeString() in src/XF/Db/AbstractAdapter.php at line 410
XF\Db\AbstractAdapter->quote() in src/XF/Db/AbstractAdapter.php at line 388
XF\Db\AbstractAdapter->quote() in src/XF/DataRegistry.php at line 137
XF\DataRegistry->readFromDb() in src/XF/DataRegistry.php at line 82
XF\DataRegistry->get() in src/XF/DataRegistry.php at line 225
XF\DataRegistry->offsetGet() in src/XF/App.php at line 1402
XF\App->XF\{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/App.php at line 202
XF\App->XF\{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/App.php at line 208
XF\App->XF\{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/App.php at line 328
XF\App->XF\{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/Install/App.php at line 33
XF\Install\App->XF\Install\{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/App.php at line 2032
XF\App->router() in src/XF/Mvc/Dispatcher.php at line 350
XF\Mvc\Dispatcher->getRouter() in src/XF/Mvc/Dispatcher.php at line 51
XF\Mvc\Dispatcher->route() in src/XF/Mvc/Dispatcher.php at line 40
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1889
XF\App->run() in src/XF.php at line 328
XF::runApp() in install/index.php at line 14


Code:
An exception occurred: [XF\Db\Exception] MySQL statement prepare error [1146]: Table 'xf202.xf_data_registry' doesn't exist in src/XF/Db/AbstractStatement.php on line 212

XF\Db\AbstractStatement->getException() in src/XF/Db/Mysqli/Statement.php at line 196
XF\Db\Mysqli\Statement->getException() in src/XF/Db/Mysqli/Statement.php at line 39
XF\Db\Mysqli\Statement->prepare() in src/XF/Db/Mysqli/Statement.php at line 54
XF\Db\Mysqli\Statement->execute() in src/XF/Db/AbstractAdapter.php at line 79
XF\Db\AbstractAdapter->query() in src/XF/Db/AbstractAdapter.php at line 116
XF\Db\AbstractAdapter->fetchPairs() in src/XF/DataRegistry.php at line 137
XF\DataRegistry->readFromDb() in src/XF/DataRegistry.php at line 82
XF\DataRegistry->get() in src/XF/DataRegistry.php at line 225
XF\DataRegistry->offsetGet() in src/XF/App.php at line 1402
XF\App->XF\{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/App.php at line 202
XF\App->XF\{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/App.php at line 208
XF\App->XF\{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/App.php at line 328
XF\App->XF\{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/Install/App.php at line 33
XF\Install\App->XF\Install\{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/App.php at line 2032
XF\App->router() in src/XF/Mvc/Dispatcher.php at line 350
XF\Mvc\Dispatcher->getRouter() in src/XF/Mvc/Dispatcher.php at line 51
XF\Mvc\Dispatcher->route() in src/XF/Mvc/Dispatcher.php at line 40
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1889
XF\App->run() in src/XF.php at line 328
XF::runApp() in install/index.php at line 14
 
Last edited:

Chris D

XenForo developer
Staff member
Yeah we've broken something here.

Could you please do a clean install of 2.0.1 and then upgrade to 2.0.2. That should work.
 
Top