1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

As Designed Can't drag and upload in overlay editor

Discussion in 'Resolved Bug Reports' started by rellect, Apr 4, 2014.

  1. rellect

    rellect Well-Known Member

    I noticed that drag and upload doesn't work in the overlay editor. This is possibly as designed, although it could be nice if that worked too.
    In any case, when trying to drag and upload it says that the option isn't available. At first I thought that something wrong with my permissions, until I realized that it's the overlay editor and in the full edit page it works fine.

    I think the message should inform you that you can upload when in the full edit page.

    upload.jpg
     
  2. Mike

    Mike XenForo Developer Staff Member

    This is basically just a generic handler -- if there's no attachment system detected in the form, we can't support uploads. (Note that you can't attach/manage files from that overlay.)

    I'm not sure of the feasibility of a different message (especially as that's also permission dependent).
     
  3. rellect

    rellect Well-Known Member

    Is there something in the overlay that limits the use of attachments? Or this is just a design decision?
     
  4. Mike

    Mike XenForo Developer Staff Member

    A bit of both really. Most significant is that the attachment upload system uses an overlay of its own. But equally, it's also a relatively uncommon action (to change attachments when editing a post).
     

Share This Page