• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Can't access forums after 1.2 upgrade

Status
Not open for further replies.
#1
I copied the XenForo 1.2 files to my site. But when I tried to run /forums/install, I get the error below. Any suggestions?

Fatal error: Uncaught exception 'Zend_Db_Adapter_Mysqli_Exception' with message 'Access denied for user 'Admin'@'localhost' (using password: YES)' in /home/rconn/public_html/forums/library/Zend/Db/Adapter/Mysqli.php:333 Stack trace: #0 /home/rconn/public_html/forums/library/Zend/Db/Adapter/Abstract.php(315): Zend_Db_Adapter_Mysqli->_connect() #1 /home/rconn/public_html/forums/library/XenForo/Application.php(643): Zend_Db_Adapter_Abstract->getConnection() #2 [internal function]: XenForo_Application->loadDb(Object(Zend_Config)) #3 /home/rconn/public_html/forums/library/XenForo/Application.php(880): call_user_func_array(Array, Array) #4 /home/rconn/public_html/forums/library/XenForo/Application.php(911): XenForo_Application->lazyLoad('db', NULL) #5 /home/rconn/public_html/forums/library/XenForo/Application.php(1294): XenForo_Application::get('db') #6 /home/rconn/public_html/forums/library/XenForo/Error.php(45): XenForo_Application::getDb() #7 /home/rconn/public_html/forums/library/XenForo/Application.php(362): XenForo_Error: in /home/rconn/public_html/forums/library/Zend/Db/Adapter/Mysqli.php on line 333
 

borbole

Well-known member
#2
Can you check the config.php file and make sure that the db info there has not being touched? Also check that the db user has full permissions to the db.
 

Jeremy

Well-known member
#6
From the error message, it looks like you are being denied access to the database. Please verify the database information in config.php.
 
#7
Can you check the config.php file and make sure that the db info there has not being touched? Also check that the db user has full permissions to the db.
The config.php file is the same, and the db user has full permissions. I also tried changing config.php to another user, and got the same error (with the "Access denied" referencing the new user.)
 

Jeremy

Well-known member
#9
Yes. You are being denied permission to your database. I would suggest asking your host if they can see an issue if you are using a valid database user with permissions.
 
#11
Making some progress -- my host changed some of the permissions on the new server, and I'm not getting the Zend error anymore.

Now I get this:

The board is currently being upgraded. Please check back later.

when I go to the /forums/install page. (The browser shows it as "/forums/install/index.php?upgrade/".) I'd expect that message if I just went to /forums -- why am I seeing it in the install directory as well?
 
Status
Not open for further replies.