1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Cannot upload custom avatars after moving servers!

Discussion in 'Troubleshooting and Problems' started by Jacoblab1, May 8, 2013.

  1. Jacoblab1

    Jacoblab1 Member

    So a few days ago I moved my forum from a hostgator shared server onto my dedicated server. I copied the database and the site's folder. Everything on the site is fine, all users are there and posts.

    The one problem I'm having is I cannot upload or set custom avatars. When I go to upload an avatar, I see the little loading bar thing, and when it's done, it says your avatar has been set. When I refresh the page, the avatar isn't changed. When a new user tries to set an avatar it just makes the avatar a missing image (http://woodpunchers.net/data/avatars/l/0/5.jpg?1367776472)
    I know that the problem is not that the data directory is protected, because I've chmod 777'd it.
    I also tried using the minecraft avatar plugin, but that won't work either.
    I'd really like to not have to re-install xenforo and all my addons, so if anyone knows how I could fix this, please let me know! If you need any more info, just ask!
  2. tafreehm

    tafreehm Well-Known Member

    Jacoblab1 likes this.
  3. Jacoblab1

    Jacoblab1 Member

    Yep, I chmod 777 the internal_data. Yeah I really don't know why it's doing this.
  4. tafreehm

    tafreehm Well-Known Member

    I would say, wait for an expert to respond here. But following are the few debugging steps:

    See if it works fine on default theme
    disable all plugins to see if that solves the issue.
    Are you able to upload images in post ? if not it could be a server side issue.

    Thats all I can think of right now.
    Jacoblab1 likes this.
  5. Jacoblab1

    Jacoblab1 Member

    It doesn't work on default theme and I tried disabling all plugins.

    I'm not able to upload images in posts either, I get this message
    The following error occurred

    There was a problem uploading your file.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Check ownership of the directories too.
    This is separate from the permissions.

    Check the Apache error logs for more information.
    Jacoblab1, Tracy Perry and 14DH01 like this.
  7. 14DH01

    14DH01 Active Member

    re-import the directory
    ftp =>/data/avatars/*all pictures
    Jacoblab1 likes this.
  8. Jacoblab1

    Jacoblab1 Member

    What exactly do you mean by "re-import"?
  9. 14DH01

    14DH01 Active Member

    the avatar folder from the old server to put in the new.via FTP​
    :rolleyes: "manual Mode"​
    Jacoblab1 likes this.
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It's probably a lack of permissions in the subdirectories inside of data and internal_data. You need to recursively set permissions for those directories.

    If you have shell access then try running these commands to recursively set permissions in those directories:

    chmod -R 777 data
    chmod -R 777 internal_data
    You might also try 755 permissions. Depending on how PHP is installed, 755 may still be writable. I have seen some server configurations throw errors with 777.
    Jacoblab1 and 14DH01 like this.
  11. Jacoblab1

    Jacoblab1 Member

    Running those commands fixed it! I didn't have the -R when I ran them so that might have been why. Thank you :)
    tafreehm likes this.

Share This Page