• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Cannot upgrade

N

Nelson T.

Guest
#3
It appears that your upgrade changed the file permissions...

It says that it won't do that.

It seems to have changed them all to 777. This is not permissible on our system.

(Sigh)
 

Chris D

XenForo developer
Staff member
#4
If all you did was upload the files then our upgrade didn't change anything. And, nothing in our upgrade process would modify any file permissions anyway.

Anything that changes the file permissions is likely something inherited from your system, be that your FTP client or server.
 
N

Nelson T.

Guest
#5
All I did was upload the contents from the XL 1.46
Everything was at 777. I got the error.

I tried to change files to 644 and folders to 750 and I am still getting this error:
The Hobby-Machinist - Error
The requested page could not be found.

I am beside myself trying to figure out how to get the site back up...
 

Chris D

XenForo developer
Staff member
#6
You would need to consult your host. It will be something specific to your setup and nothing that uploading a set of files will have caused.
 

Chris D

XenForo developer
Staff member
#8
That would suggest you no longer have an "install" directory.

It may be an interesting exercise for you to re-upload all of the files, again. First of all it will put the install directory back where it should be, and second of all it should confirm that this won't happen every time you upgrade and your hosts have fixed it properly.
 
N

Nelson T.

Guest
#16
Shortly after Mike's post it seemed to be working. What did you do to resolve it?
My web host discovered that it was an .htaccess file that somehow had me restricted after the upgrade files were uploaded.
They deleted the file, and I was suddenly able to perform the upgrade.

I do not know how the .htaccess file resurfaced- it was not a problem BEFORE the upgrade (I had full access.)