Third party Cannot open editor menu in RTL

Affected version
2.1.4

Sadiq6210

Well-known member
Unfortunately this is not fixed in 2.1.5

@Kier @Chris D @Mike
guys,can you have a look to this issue please? At least if you can confirm if this is a bug in the software? we cannot check it here as you don't have RTL option.

Many of our users are complaining that they are not able to open any editor menu in mobile, for example they cannot align the text and they cannot change the font size!. If this is a bug, then it should be considered as a crtitcal with a quick fix, just imagine that nobody can open any editor menu in Android mobile in all RTL forums!
 
Last edited:

Jeremy P

XenForo developer
Staff member
I can reproduce this. Trying to open a Froala menu on any RTL language just scrolls to the top of the page. This seems to be limited to Chrome on Android.
 

Chris D

XenForo developer
Staff member
While I can confirm that this issue exists, unfortunately I don't envisage there being a quick fix for it.

I believe it is fixed (or at least behaves slightly better) in XenForo 2.2 (which uses Froala v3). However, because Froala v3 exists, there doesn't appear to be much urgency in terms of maintaining the existing v2 branch and will soon reach a stage where it receives no further updates.

While this is unfortunate, I do not believe the issue to be quite as extreme as you describe and there is a workaround.

From your video, you are trying to access editor buttons without the editor being focused (no cursor in the editor, no keyboard displayed). This does indeed produce the behaviour you describe, but as a workaround it seems as if you focus the editor first, and then click the editor button, the page doesn't scroll.
 
Top