1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can´t upload new Avatar

Discussion in 'Troubleshooting and Problems' started by bogus, Dec 30, 2010.

  1. bogus

    bogus Guest

    I´ve tried to change my old Avatar pic, i have imported from vb4, but i cant. The Picture wont change after my board uploaded it successfully.
    Rights are set to allowed, data and internal_data is set to 777. If i delete the old avatar it changes into the xenforo standart. If i try to upload another picture i get "All attachments succesfully uploaded" but it does not change....
     
  2. Lawrence

    Lawrence Well-Known Member

    Have you used the avatar editor (pop-up) for removing and uploading your avatar? yourName -> Avatar. I just checked this and could not duplicate. I checked the check box to delete my old avatar, ensured Use Custom Avatar was selected, and pressed the browse button to upload a new avatar.

    The confirmation on a successful avatar upload is: Upload Completed Successfully. There should be no confirmation about attachments.
     
  3. bogus

    bogus Guest

    Have you used the avatar editor (pop-up) for removing and uploading your avatar? yourName -> Avatar <-- Yes
    I checked the check box to delete my old avatar, ensured Use Custom Avatar was selected, and pressed the browse button to upload a new avatar. <-- Did exactly the same


    Well i was trying that. Deleting the old Avatar. Went back to the standart one.
    Then i uploaded mine, message:"Upload completed successfully" and i get my old Avatar i deleted just before.... Very strange
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Which version of software are you running?
    Have you made any changes to the style, files, add-ons, etc?

    I'm not seeing this issue on my local or live installs (beta 4 and 5) or here.
     
  5. bogus

    bogus Guest

    I am running the newest Beta with the following addons installed:
    • AzuCloud 0.0.2
    • ragtek New User Thread 1.0.0
    • rpgBridge 1.0 - private addon to include an extrernal rpg game side
    • The Happy Place 1.0
    • VigLink 1.0
    • [8wayRun.Com] XenCarta (Wiki) 1.0.4
    • [GP] Donations 1.1.2
    I also installed
    http://xenforo.com/community/threads/hide-breadcrumb-on-index-page.9585/
    http://xenforo.com/community/threads/adding-advertisements-with-template-edits.6218/

    Also some changes to different Templates to get it fit to my suits
    May i give you an admin account to have a look yourself?
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    By all means, send me an Admin login via PC and I can take a look.
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Hmmm, there seems to be an issue with images in general.

    This is what I get after uploading an avatar:
    upload_avatar.PNG

    And this is what I see when logging in to the ACP:
    admin.PNG

    I've seen this problem before, I need to see if I can find the thread to see what the issue was.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

  9. bogus

    bogus Guest

    Well, its just a webspace. I have to tell my provider. but.. maybe this phpinfo helps
    hmm its off
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    It's set to off.
    I'm not sure what could be the cause of the problem then :confused:

    I just checked the URL of my avatar and it doesn't exist, even though the software has it set as "data/avatars/l/0/210.jpg"

    Can you try disabling your add-ons and/or creating a new style?
     
  11. bogus

    bogus Guest

    Hmm, thats bad, even if you do not know ;)

    Done. The new Style is added, all addons are diabled
    If u want/need, i can send you a ftp account too?!
    Send you a ftp account to private

    edit\ Hmm... I.ve done a xenforo test installation. There it works
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    Is that on the same server?

    I suspect it might be something to do with an add-on.
    Even though you have disabled them, there might be something still causing problems.
    It could even be a conflict between multiple add-ons.

    You could try enabling debug mode and/or checking the error log in the ACP.
     
  13. bogus

    bogus Guest

    I have enabled the debug mode, but... I can't figure that out :confused:
    btw, yes it is the same server
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    I'm just having a look in the ACP and on the server now and I can't see any errors/logs at all.

    I would systematically start removing each add-on completely to try and identify the cause.

    Have you made any file edits apart from the add-ons?

    Edit: I've just noticed your sub-directories in /data/avatars are 755. I suspect an add-on has changed those from 777 which could be the cause of the problem.
     
  15. Brogan

    Brogan XenForo Moderator Staff Member

    Yes, that was the problem.

    I just changed the file permissions on all sub-directories under /data/avatars and it's now working.
     
  16. Brogan

    Brogan XenForo Moderator Staff Member

    I'm fairly sure it was the permissions on the sub-directories, I seem to recall someone else had the same problem after installing an add-on.

    I'll see if I can find the thread and whether it is the same add-on.

    You should disable debug mode now as it's not recommended to run that on a live site.
     
  17. bogus

    bogus Guest

    WOT? :eek:
    Oh Dear, I really have to thank you. Almost deleted all addons, also the Wiki ;)

    Oh ok.. Brogan.. Once again you helped me a lot. I owe you something...
     
  18. Brogan

    Brogan XenForo Moderator Staff Member

    Where is your test installation? On the same server?
    And did you install all the same add-ons?
     
  19. bogus

    bogus Guest

    Yes. its on the same server.
    Not yet. I wanted to install them.
     
  20. Brogan

    Brogan XenForo Moderator Staff Member

    All the evidence points to one of the add-ons then.
    The only way to find out which one would be to install each one in turn and then check the directory permissions.

    Don't forget to disable debug mode :)
     

Share This Page